Ternary Operation not evaluating correctly for [MOON_TY]

I am trying to show the phases of the moon on a face. I have 8 images and I have set each one to color opacity 0 to hide. I am trying to set the opacity to 100 for the correct MOON_TY. I have this ternary statement in the TAG section of the Color Opacity. ([MOON_TY]==0? 100: 0) This is done for all 8 images respectively and each value is set accordingly for each phase to evaluate as 1 (True). This logic works fine Watch Face Studio preview but when loaded to a watch the image never shows. I have also even added a debug test box with the TAG set to [MOON_TY] and it shows 6 on the watch itself indicating that the value is being set correctly on the watch in the TAG expression. I even moved the moon phase image group to the front layer to ensure it wasn’t being hidden behind some other element. Again, like I said it shows properly and correctly in Watch Face Studio preview window but not on the watch itself. Any ideas??

Try it with correct bracketing


(([MOON_TY]==0)? 100: 0)

If this works…means wfs is not as strict with its syntac but on the watch its is. And the resulting number is wrong

Actually I had this in brackets for the purpose of the post. The actual statement was [MOON_TY]==0? 100: 0 and I also tried it as you suggested, (([MOON_TY]==0)? 100: 0). Both evaluate and show properly in WFS preview but not at all on the watch itself. Watch is a Samsung Galaxy Watch 6 Classic. I’m not sure what else to try.

Hmm, working on my gw 5 pro.
If you dont mind post your wfs example here.

To do that e.g watchface.wfs

Rename it to watchface.zip

I see if i can find out the issue. Is it your watch or wfs

Thanks Knightwing. WatchfaceExample.wfs attached.

It is my new GW6 Classic and again, it seems to work in the WFS preview but not on the GW6 Classic when uploaded to the watch for test.

The weird thing is even without tag just 100.
Your image doesnt appear

I suppect the project was corrupted

I did the same test as you and even with no TAG statement and at 100% it does not show for me either. Very nice WFS, I have a lot of time in this actual face design and I guess now I have to recreate from scratch? could it be maybe the png files I’m using? the size or resolution of them??

I am fixing the issue for u now…no need to redo. Just the moon thing.

Will sent u a new wfs soon

Thank You KnightWing!! Very much appreciated

just rename to .wfs see if this helps for you version of the watch.

if not just delete all the moon face and redo the tag expression .

you may also delete the file you sent to me by editing if you don;t want to share it to others.

like me know if you fixed it. I delete my copy also.

Thank you so much Knightwing. I never though about deleting the images and group and re-adding them. I did this and it seems to work fine now. Doesn’t say a lot about WFS’s ability to maintain structural integrity of components within a face, but now I know if I get some weird behavior, recreate the element and try again!!


There is a known issue with caching of assets. It is very rare so I don’t know if they have found the cause yet. If you haven’t deleted the original project it might be helpful to submit it to Developer Support.

Samsung Developer Relations

Sorry to join in so late . I had a similar problem . I can not remember What it was and how I solved it . But sometimes a Rebuild is the only Answer . I have found with all these things if I try to do something quickly stuff goes wrong . I had a struggle with Sketchbook the other day after buying it . A Reset brought it up with the Default Language Chinese Simplified . Glad you have it sorted . A good topic for Book Marking . Well Done @robbiefreeland and @Knightwing