Text does not appear in GWD after launch

I often have a problem that GWD does not display the font. Sometimes it doesn’t even display Samsung’s own fonts. This is very annoying. How to get rid of this problem forever?

This has to do with Watch Designer Suite caching. You need to restart your computer (don’t just turn it off and on but use restart). That clears the cache and the fonts appear again.

Samsung Developer Program

1 Like

It did not help. I also tried clearing the font cache on Windows manually. Deleted DAT files, but nothing helped. But if I add a new font it is displayed. Is it possible to delete unused project fonts? I also noticed that the project stores all the resources, even those that are no longer in use. How to manage resources and fonts?

If it isn’t the updated GWD that is the problem it probably has something to do with the font.

One thought is that if you are you using Weather complications and it is an updated project. Try to change the language settings for all the digital watch face then change them back. They added more languages and that overruns the buffer of the old project so some resources aren’t shown. For example from all to default English then back to all. That may help, if it is an older project updated.

While all the resources and fonts are stored in the project file (.gwd) they are not included in the Binary (.tpk) file that is installed on the watch.

Try this with a copy of your .gwd file change it to type .zip, open it, remove the unused files and then rename it back to .gwd. See if Galaxy Watch Designer opens it. I never tried it myself but it should work if you had a huge .gwd file and low memory.

Samsung Developer Program

I think I managed to solve this problem.

  1. Created a new project, uploaded my font there. The font works.
  2. I opened my previous project with this font and everything continues to be displayed.