Tizen ERROR- failed to connect to remote target [ip]

My Tizen Device Manager could not connect to Remote Device Manager (Samsung smart TV )in Tizen Studio, I tried everything, each time I get the following error

failed to connect to remote target ‘’

**The problem was fixed when I used mobile hotspot instead of wifi connection. ** but I want to work it anyhow with wifi.

It was working earlier , not sure what happen and not working now.

If it worked with the mobile hotspot and not your WiFi I would assume you either have a Ethernet cable plugged in or your router has different networks for 2.5 Mhz and 5 Mhz frequencies and that is an issue.

I rarely get it to work if I have an Ethernet cable plugged in.

I hope it as simple as that.

Samsung Developer Relations

But I didn’t made any changes , earlier it was working fine with Wi-Fi as well , I really don’t know what should I do, as I already reset my Wi-Fi on TV and still it’s not working, how come it stops working all of sudden without any change?

I know that older Apple Router/Modems change IP addresses or networks all the time,

Windows or Mac OS updates may have an effect.

I had one person who’s TV was selecting his neighbors unlocked WiFi

Anyway if it worked on HotSpot but not on the WiFi network they aren’t connected to the same Network.

Samsung Developer Relations

So How can I confirm it that they are under same network or not as visibly I can see my windows laptop is connected to my wifi same as TV and I can see IP of each , which is also same as earlier , didn’t changed. So how can I make sure that they both are connected to same network? should I format my TV? or reset anything like wifi on TV or something? which might can help?

Any suggestions?

I’d try a soft reset first (unplug the Modem/Router for a couple minutes) and the computer (restart not off and on) as well maybe it will just sort itself out.

Hopefully that puts things back on track. If it doesn’t You should be able to tell access your router tools from a browser http:/ You will need your admin password You can see all the connections there.

Check your computer setting and TV setting and see if it is on a different network 2019 and newer you want 5Mhz older is 2.5 Mhz

Some WiFi routers have the 5Mhz and 2.5 Mhz on different networks I don’t think this is true with newer ones. Almost all computers will have the Ethernet on a different network than the WiFi so that needs to be off.

Hope this helps,

Samsung Developer Relations

Thank you Ron for guiding me. I restarted my Wi-Fi and now it’s working fine.