TWA : The splash screen does not appear when Samsung Internet is the default browser app

Describe the bug
The TWA splash screen does not appear when Samsung Internet is the default browser app.
When playing A2HS on Samsung Internet, the splash screen works. But it doesn’t work in bubblewrap TWA.

To Reproduce
Steps to reproduce the behavior:

  1. Go to setting > application > default application > browser
  2. Browser app > Samsung internet

Expected behavior
Splash screen works.

Screenshots
Nope

Smartphone (please complete the following information):

  • Device: Android phones including Galaxy 10
  • OS: Android
  • Browser Samsung Internet
  • Version 14.0.1.62

Additional context
The following message is displayed in logcat.
W/SplashScreenStrategy: Provider com.sec.android.app.sbrowser doesn't support splash screens

1 Like

Hello @jerome.larman ,

Hope you are doing well! We would like to apologise for the delay in response.
We would like to request you to update to the latest version of Samsung Internet Browser and try again.

If the issue still persists, we would like to request you to share your TWA installation link along with a screen recording of the issue and reproduction steps to help us investigate your issue.

Please let me know if you have any further queries. Looking forward to hearing back from you soon!

Best Regards,
Shuvo
Samsung Developer Program

Hello, you can use all PWA to TWA example.

I can not see instance of TWA processing splashcreen. The adb logcat mention W/SplashScreenStrategy: Provider com.sec.android.app.sbrowser doesn’t support splash screens

For example :

git clone https://github.com/GoogleChromeLabs/svgomg-twa.git

Thanks in advance.