Unable to customize the watch face through the phone app

Hello everyone!

I’m unable to customize the watch face through the phone app. Interestingly, some watch faces can be adjusted via the app, while others simply cannot, displaying an error message: “Something went wrong. Please try again.”

What’s even more puzzling is that the same watch face occasionally works from the phone app at different times.

If anyone has insights or solutions to this issue, please share your information. It’s disheartening to encounter users’ legitimate complaints about this problem.


Two things come to mind
This was an issue last year that wasn’t resolved until a Software update on the watch. Do you have the newest wear OS / One UI version

Second things is that there are reports of issues with Watch Face Studio projects that went from an older version directly to a newer version without going through V1.3.13 and then V 1.4.20

If neither one of those apply do a reboot (press and hold both buttons until the screen goes blank) Not just shut down and restart and see if that fixes it.

There is also an option to reset the watch but you will have to reinstall all apps and watch faces again.

Samsung Developer Relations

That might be my case. I began working on my watch faces last summer but got distracted and only resumed a few weeks ago. I’ve updated WFS to version 1.6.9. Is there a way to update my projects to fix this issue?

For me it’s always been sketchy. There was a stretch where it didn’t work at all and that was seemingly fixed. Now it just randomly works or crashes on me. (Oppo Reno8T/GW5 Pro) Too afraid to update my WFS at this point so still working in 1.5.7. :>

So far on 1.5.7 wfs , gw pro 5, samsung s23 ultra
With lastest updates.

No issues… so i think this is not due to WFS.

But phone and watch firmware

Only notice when loading the faces wfs, or factory it takes a long time to load on the app

Just tried to rebuild my watch face from scratch in a new file and ran it on my updated Pixel Watch 2, but the issue persists. The phone app continues to display the same error: “Something went wrong. Please try again.”

It’s becoming frustrating, as I can’t pinpoint the cause or understand why some projects work seamlessly and others don’t.

I’ve heard that @amoledwatchfaces successfully resolved this issue. Could you please share any tips on how to avoid this problem if possible?

Refer to this reply.

Stated , wear os version
One ui version

Wearable app version

Like i said its within phone or watch not the project.

I’m experiencing it right now. I’ve updated everything that can be updated and am now trying to manipulate the project to see if specific conditions cause editing via the phone to crash, and there seems to be a correlation. However, I don’t fully understand it. It might be related to either the number of options or the size of the file. For instance, I have a watch face with 4 customizable features, each with 10 options, and it works fine.

Meanwhile, I have another watch face where I’ve limited the customizable features to 4 with 5 options each, and it doesn’t work. Yet, it works if I remove more options. But not everytime :person_shrugging:

As @Knightwing said what Pixel Watch do you have what is the wear OS ersion.

If you have Wear 4 then re-pair your watch and mobile, that will reset everything

Samsung Developer Relations

Ron, thank you for the response. I apologize for the miscommunication. What I intended to convey in the original topic is that the issue isn’t isolated to my device alone; I’m also receiving about 20-30 reports from customers using various wearable devices and phones. Given that this issue appears randomly across different projects, I’m inclined to believe it’s not related to Wear OS or the Watch app specifically.

By customizeable options do you mean just complications or do you mean Styles and Hands and so on?

The "Something went wrong. Please try again.” sounds like a Google Play Service notification In any case since you can reproduce this Open a Developer Support Request and they can tell you how to get a log for both your phone and watch and then analyze it.

Hope they can help

Samsung Developer Relations

Hi. It’s Google DWF performance issue. How many Complications do you have? Are they very complex (multiple layouts)? Something went wrong message usually shows when customization editor receives timeout when loading custom complications.

Just don’t bother with support tickets / don’t re-pair your watch. Google knows about this issue and will hopefully solve it soon.