USB+BT connection

I have debugging on my S8 so SDBoverBT runs. I select the Galaxy Watch (0CBB) and it says Bridge is connected, socket enable, BT enable, SDB Port 7135, GDB port 26102. However GWS only sees the phone, no sign of the watch.

I tried the WiFi way too but although the watch says that it is connected successfully, I couldn’t find any sign of it on the network so I couldn’t produce an IP for GWS.

Any advice?

It probably isn’t connecting because you didn’t accept the RSA key first time.

Go to Settings -> Gear info -> About device.
Tap on Software version 5 times. Then a confirmation pop up displayed once the Developer options is enabled. (OPR checking only at this time)
Make sure Debugging is on in About Watch settings
Hold down the home key until rebooting appears.

Connect your phone to your computer.
Allow Data Access
On the phone make sure USB debugging is enabled in the Developer Options

From the \program files\Galaxy Watch Designer\Tizen\Tools
copy sdboverbt_160523.apk to your phone and install it.

In older versions of Windows you may need the Android USB Drive for Windows on your PC you can get it here. https://developer.samsung.com/galaxy/others/android-usb-driver-for-windows

Make sure debugging is enable for both your watch and phone

On the phone enable USB debugging in the developer Options

Launch SDBoverBT on your phone

It will ask you to select your device it will show your watch click on it and it will be connected
You will have to agree to the RSA encryption or some other permission the first time and it doesn’t show very long so be sure you have your watch handy and running when you do that.

Once you are connected plug your phone into your computer and allow data transfer on your phone
launch GWD and from your project chose run on device
It will start the scan and then it will show the SDBoverBT icon

Thanks for the quick reply!

I did see that RSA key thing before but only for a split second before the screen went to sleep…

So I enabled the developer mode on the watch. There was no confirmation dialog only a statement: “developer options turned on”.
The debug mode was already on so I turned off, rebooted, turned on, rebooted again.
On the phone USB debugging was enabled, so I turned it off and back on.
sdboverbt was installed already so I just started it. I selected the watch:

BT is connected:
Galaxy Watch (0CBB), 0C:
2F::::
Socket: disable
Bluetooth: enable
SDB port: 7135, GDB port: 0

I kept the watch awake but no sign of that accept RSA dialog…

The RSA Encryption key needs to be accepted if you don’t the first time the system thinks it is someone trying to access your device and doesn’t show ever again. The way to force it to show again is hold down the home key for about 15 seconds until it says rebooting.

The encryption key doesn’t show until you try to send something to the watch. Then next time you connect to the device with GWS keep the watch active and accept the encryption key. You can then generate a distributor certificate and install your design on your watch.

Ron
Samsung Developer Program

I couldn’t make it work, got no RSA acceptance dialog whatever I did. So I tried again with WiFi and this time around all went down as described in the docs: I have a connection now!
Thank you for the help!

I’m glad you got it to work It has been a while but I think I needed to accept the RSA encryption key the first time I turned on USB debugging and connected the phone to the computer and launched the SDBoverBT mobile app.

Ron
Samsung Developer Program