USB massive storage not recognized in Galaxy S20, Android 11

USB massive storage not recognized in Galaxy S20, Android 11.

The built-in file explorer shows files in USB.

But in android api such as android.provider.MediaStore.getExternalVolumeNames(Context), the mount path not found. (It shows Primary and sdcard path. )

In Android 11 below, it works fine.

I think it is compatibility issue.

Please let me know how to list up files and open files in USB(OTG).

What about non samsung devices with Android 11 ?

I didn’t test other device except for Galaxy S20+ yet.

Same problem.
I tried connect with other devices too but only my new S20 Android cannot connect with my PC (Win10).
S7 and S9 without problem.
I tried do add USB drive and result without problem.
If its android problem, i hope this issue will be soon repaired with next update.

You should try a non-samsung device first. If it is a problem of Android 11, then you should submit an issue on google issue tracker.

My programs have a related (if not the same) problem: the former USB drive mount point at “/storage/xxxx-xxxx” no longer exists as of the Samsung Android 11 update. Not being able to address the USB drive is a killer for backup/sync programs. Mine are POSIX based, but run by legacy apps that should get an opt-out of 11’s permissions changes.

Has anyone been able to verify this regression on a non-Samsung device yet? I’ve posted this in a few other places, but it may just be Samsung. To verify: “adb shell ls /storage/xxxx-xxxx” fails for the USB drive’s ID number (reported in some file explorers).

An update for anyone stumbling onto this: Samsung replied that they cannot do anything about this, because it is a new Google policy as of Android 11.

The reply clarified the “/storage/xxxx-xxxx” paths can no longer be set. It also verified that USB drives can still be mounted at path “/mnt/media_rw”, but this path requires special permissions or rooting, and is of course inaccessible to most programs and users.

Assuming this qualifies as official, it means that it’s not just Samsung devices, and it’s up to Android to make USB drives generally accessible again.