Can't connect WFS to Galaxy 5 Pro

I’m trying to load a watch face from GWS to my 5Pro. The watch is normally paired to my Galaxy S21 Ultra, nad I can also pair it to my PC (Windows 11). I can also ping it from the PC and I can connect both the PC and the watch to my phone hotspot. However, I cannot get the watch to connect to GWS. I’ve enabled debuggin, both BT and WiFi and installed sdboverbt, as per the Samsung directions. I’ve been searching the web and it seems that sbdoverbt is for Tizen and that doesn’t work with the Galaxy 5. Can anyone help me with this? Thanks!

I think you need to create with latest version of Watch Face Studio and based on API 30.

To expand on @nobel.mixed reply

Galaxy Watch Studio is for Tizen platform Galaxy Watch 3 and older watches.
Galaxy Watch 4 and newer use Wear OS Powered by Samsung operating system. So you need Watch Face Studio for that and it uses ADB instead of SDB for connecting to the device. Both now need to use WiFi debugging as Bluetooth debugging is considered a security issue now.

Watch Face Studio will fill familiar but totally different all at the same time. Feel free to ask for help here on the discussion boards.

PS I love my GW5 pro

Samsung Developer Relations

1 Like

Having the same issue with Run on Device for WFS. Is there a certificate or something i need to get or is it configuration?,

I finally figured out out, with the help of someone in the internet. Slightly smiling face :slight_smile: The Galaxy Watch 5 needs Watch Face Studio. Once my face was ready, I turned on the hotspot on my phone and connected both my PC and my watch to that network. Turn on wifi debugging on the watch (there are two buttons for that) The first will ask for permission to debug on that network, I told it to always allow. Once you’ve turned on the second one, click the plus to pair to a device. It will give you the IP, the port number, and a six-digit code. In Watch Face Studio, click on “run on device.” Click the plus to manually add and enter the IP. In the list section, it will ask for the port and the code. Enter those and hit enter. It will take to the first window but now you should see your watch. Click on it and it will load your face. You have to enter the port and choose each time you go to upload a watch face. They both change every time.

The port and IP address should not change for most networks. The port should always be 5555 unless it is being used by some other app. I believe you may have ADB in your path and WFS uses some script relative to it location for running on device. That might force this.

Glad you got it working.

Samsung Developer Relations

@ddibling has most of this correct. The IP address should not change and the port will probably be 5555 and you don’t need to enter that.
You can’t debug watch via Bluetooth with Wear 3 and newer. It is a security risk it has to be on the same Wifi network.

Let me know if you have other issues.

@ddibling @rog1598215254 Be sure to turn ADB debugging off after you run on watch it really eats up the battery if you leave it on.

Samsung Developer Relations

Every time I connect with my Galaxy 5 Pro, the port changes. The IP stays the same, but not the port.

1 Like

Interesting, I’ll remember that next time. Never say Never :slight_smile:

PORT 5555 makes possible the transmission of a data from one computer to an application running in another device. So it may be in use or reserved by some other app.

Thanks for correcting me, I hate giving out bad information more than once.

Samsung Developer Relations

FINALLY got mine going and moved 2 faces over but i havent a clue what I did. It just all of a sudden showed a screen on the watch that gave IP and port data. Took several tries before it worked but eventually it did. And pretty stable. I’ll wait a couple days, work on another face, and try it again. This is pretty much how GWS worked for me.

1 Like

Got it to work once but it still aske for a code and port every time. And still doesnt connect!

1 Like

You have got to Persuade your modem to stick to the IP address for your watch . I am not sure how it is done . Google the Make of your Modem and the Providers Manual . You will need your Admin Password. I have a lot of trouble when I travel anywhere and want to work on WFS . I can not tell you any more than that , as my IP address never changes . Every time I want to send a Face to my watch from WFS I need to refresh the wifi connection on my watch . A reboot of the Laptop is often required . After that it is perfect for that session .

You misunderstand. My IP address doesn’t change. The ports do. When I select Run on Device a window come up that eventually asks for IP Port and Pairing Port along with a code. It also shows the same IP address each time. I get the info off my watch and it changes every time I access it. It’s part of the Wireless Debugging option.

1 Like

OK . Sorry . I never use the Port Number . As Ron has said it is not necessary so I am as lost as you are now .

There is on issue that I know of. It is when someone has a second ADB on their computer and Watch Face Studio tried to use that it will fail to connect.

Do this
Using File manager copy the address where you installed adb by default
(copy the address as text from file manger using right click on the address bar)
Open a command prompt
navigate to the folder address
cd C:\Users\USERNAME\AppData\Local\Programs\WatchFaceStudio\tools\window
Then type
adb connect 192.168.x.x:5555 (where 192.168.x.x is your watch’s IP address).
It may take a minute to connect or give a failure response
If you get a rejected error or something check your watch debugger settings.
Try in developer options to revoked permissions and force new acceptance. do the connect again.

It is rejected because port 5555 is in use you need to find what is using that port.

Samsung Developer Relations


I had the same issue and it asked me all that port information and such… the issue was after you enter your IP address you have to OK file transfer from computer to watch. you click ok and do not ask on this device again.
My computer had done an update and it’s signature changed and it took at least 30 seconds before the notification showed on my watch. I never had to fill in any of the greyed stuff about port and pairing .

So just give it a while and then clck to allow it on your watch.

I hope that was what you were seeing too.


1 Like

Me too! I’m working on a new face and wondering if I’ll be able to upload or not. Now if I can just figure out where the App ID goes…

I see this was answered elsewhere. For anyone else it is done as an custom Action on a Text or Image component.

Samsung Developer Relations


Thanks Ron. Do i have to give you a W2 for all this help?

Hi, I also had an issue to connect my Watch 5 to WFS after Wear OS 4 update. I tried everything with the same error :

The single thing that helped was to enable “Wireless debugging” in “Developer options” and enter all data like on the image :

Just it required the same action each time when I try to connect my watch to WFS in a new section. Somebody know how to fix it?

That the only correct way to do it. You have to redo if your wifi connect on your watch is disconnected due to time out. Do a search on this u will come across something i posted to resolve the wifi connection.