Watch face rejected - signature1.xml invalid

anyone who knows what can cause this ? should I only rebuild tpk files ?
Does it have anything to do with the author certificate ?

Because the TPK files are just compressed files, the contents can be modified. However, manually modifying the TPK contents will conflict with the original TPK hash values created by the tool, and it can’t be uploaded to the store. It’s a way of ensuring there isn’t anything fishy going on.

I’m not saying you modified the TPK however this could be a cause. Otherwise, if you just uploaded the TPK created by the tool, you may have to submit a question to the portal asking what the problem is. It doesn’t sound like a certificate error if this is a new face.

You get this error if you use a Tizen and not Samsung Author or Distributor Certificate if you are building a Galaxy Watch App with Tizen Studio. You must have a Samsung (Tizen) Author and Distributor certificate.

You will also get this if you have a different Author’s certificate and try to upload a newer version of the file to the store

Samsung Developer Program

1 Like

This was 3rd update of my watch face created with GWS 2.0.0. I didnt change author certificate from the creation date (2018).

It is possible that this was caused by some error in tpk creation via GWS ?


How to update to store.

  • package ID is not same thing as file name. Package ID must remain same across all updates. You can see the package ID in the Build window in GWD. Leave that alone!
  • version number is just below that - CHANGE it for each new version, and make sure the newer one has a higher number.
  • once you build your project you will have a XXXXXX.tpk file - rename it directly through your file explorer, because file name MUST be different for each uploaded binary.

Samsung Developer Program

1 Like

Ive tried rebuilding tpk again. Hopefully this was gws issue.
Im uploading and updating watch faces continuously without a problem for about one year so hopefully this was just error from GWS.

Also it looks like you have been solving this few months ago

I’m believe that one last year was using a Tizen Store author signature but I may be wrong. But if you are using GWS that isn’t it.

Hopefully rebuild and reupload solves it.

Samsung Developer Program

1 Like

Hello Ron,

Is there a possibility that this isn’t working because I’ve created new author certificate via Tizen Studio ? This was used just only for education purposes. Keystore folder & certificate in GWS remained untacted

Edit: I was creating Samsung Author Certficate in Tizen Studio - needed to log in via my Samsung account to create it (wanted to manually push bp & ekg apps to watch). But created certificates were stored in different folder. (Nothing to do with GWS I think)

Can this be problem ? And if yes, how can I revert my Samsung account to use old author certificate so I can publish watch face updates without a problem ?

Edit 2 : Compared new builded tpk with the tpk builded on my old computer - author-certificate files in signature are same. But comparing signature1.xml there is difference in signature value & in one of X509Certificate lines. I tried replacing distributor.p12 from my old PC and values in singnature1.xml after rebuild are matching. Could this be problem with distributor certificate ? (Newer distributor certificate was created for Galaxy Watch 3 (retail demo device). Its possible that this is causing the error ? I thought that only author certificate is needed for watch face publishing. Sending new update to the store for approval - created with old disctributor certificate (no GW3). If this one will pass, there is definitely problem with distributor certificate (used for retail demo GW3)

Ive just tried using Tizen Studio Certificate manager (Samsung Certificate) to check my author certificate. Its showing that it expired one year ago ? Problems however occured one year later (this year), till now everything worked fine.

Should I extend my author certificate ? Will this new certificate work fine for updating old apps ? (assuming its generated from old one)

Distributor certificates are only for testing and are specific to a phone. When you upload to the store the distributor certificate is replaced by a Samsung so it can’t be a distributor certificate error.
You can have multiple devices in the Distributor Certificate so it would not be strange for that to be different.

Many sellers use the same Author Certificate for both Tizen and GWS they import the GWS into Samsung. There could have been some cross contamination. We have a lot of warnings to back up the author certificate when you create it perhaps you have that. saved. Since you have it in your old computer I think you are good with that.

Save what you have now (just in case) and replace it with the older version in the Keystore.

I see a note about removing the hidden .metadata file but that was regarding Tizen Studio projects.

Let me know if restoring the older Author Certificate worked.

Samsung Developer Program

Hi Ron,
thank you, i will definitely let you know.

But I would have one more question. Is it possible that when a person creates a new author certificate (samsung) in TIZEN STUDIO (needs to log in via a Samsung account), then his account is somehow linked to this new author certificate, which means that he cannot use his old author’s certificate to update his watch faces anymore? Or it just depends on what certificate the watch face was built on?

Because I only used Tizen studio (and created an author certificate) once when I tried to install the ekg monitor app (followed XDA guilde). I have never used this author certificate again.


It depends on the app that it is built on. In tizen Studio you can have multiple profiles with a different Author or distributor certificates.

My thought is that you have somehow corrupted the Author’s certificate. If you have the back up just use that.
If it doesn’t work then we can look for other alternatives.

Samsung Developer Program