Certificate Error

Created brand new watch face and new certificate. i get this error loading to watch. same with old certificates.

I’m going to assume you were able to install other watch faces in the past and it isn’t an RSA key acceptance issue.

I think you are running into a Cache problem Restart your computer. Make a slight change to your design and rename the package ID and try to run it on the watch again.

I’ve seen this error if you already have content on the watch with the same Package ID.

The other issues I’ve seen of this was because the watch face failed to load for some reason such as the AOD was too bright and a new Distributor Certificate was created but the old one is cached in GWS so now you get an expired certificate error.

If that doesn’t fix it and the watch and computer times are the same. I probably need to have more information.

Ron
Samsung Developer Program

I am having exactly the same problem. I did what you said, rebooted, saved and rebuild after slight change, but I still get this

Try this,
In c:\Users\USERNAME.tizen (note it is a hidden file) there is sdbkey and sdbkey.pub. hide, rename or move them to another folder.

Restart your computer to clear any cache and relaunch GWS
do all the normal things again on your watch be sure debugging is on tap 5 times on software to enable developer options if they aren’t on.
reboot your watch by holding down on the home key until it says rebooting.

set your watch face as a pre-installed watch face
and try to connect from GWD and watch your watch face
keep your watch active and watch for the RSA acceptance
if it shows allow it
If you still get the error message then it is probably a bad certificate and we can deal with that.

Ron
Samsung Developer Program

Thanks for the help, Ron: much appreciated! Alas, I still get the same error, although I am in the dark about how to set my watch as “pre-installed”. I never tried to edit an existing watch…
So, it might be the certificate…

What I did:

  • I put the files you mentioned in a different folder;
  • Re-booted the PC;
  • My watch already was in debug mode
  • Re-boot on the smart watch
  • I accepted the RSA Key blah blah
  • Then I uploaded the watch face using wifi.

Same error.

Mind you: this error first occurred AFTER updating to new version. Before, I used GWD…

That helps a lot, Now I know the error better, and it isn’t what I was thinking.

Check the time on the watch your phone and your computer make sure they all are the same time.
Rename your .tpk file so there are no spaces in the name. You can’t upload to the store if they have spaces so that might be an error side-loading too.

If those two aren’t an issue try creating new Author and Distributor certificates (keep the current Author Certificate) Oh and you have Tizen Studio Author Certificate it won’t work.

Ron
Samsung Developer Program

…Oh and you have Tizen Studio Author Certificate it won’t work…

??? Meaning?

I did rename the name of the watch face using underscores. Checked the time: no problem there.

Errormessage:

I am going crazy. I tried to make a new author certificate. I was presented with the two step entry (SMS), entered the code I received, but the “Verify code” button stayed greyed out… Simply NOT possible to enter the authorisation code…

It should have said oh if you have a Tizen Authors Certificate.

I’m confused when you click on in GWS Build menu to generate an Author’s certificate it does not have any SMS two step are you logging into your Samsung Seller Store Account or using Google/Facebook don’t use them Log into your account in the dialog.

Ron

Hi Ron,
For some stupid reason it doesn’t also recognize my Samsung watch Gear S3 anymore…
Somehow the problem keeps getting bigger and bigger with each attempt to remedy this…

Gear S3 was upgraded to Tizen 4 last year. You will need a new distributor Certificate for that, if you haven’t updated your content since then that might be the error not the Author’s certificate.

Not finding the Gear S3 can be one of many reasons. This is documented in FAQ 23 with full instructions on how to trouble shoot the problems.

If it is a firewall issue I can help you with running it by Bluetooth from a connected mobile.

Ron
Samsung Developer Program

I followed up each and every suggestion you gave me and…

VICTORY!!!

It finally worked!!

Thanks Ron, and sorry for being a pain in the *ss!! :wink:

The thing about it is that a month from now You’ll wonder why it was so hard the first time. :slight_smile:

Ron
Samsung Developer Program

No, I will be wondering why I did what I did for the fourth time already, and why it didn’t work the first three times…
Thanks anyway!