Watchfaces Dont have a Label After Being Published


Im having a very strange issue since my last 5 to 6 watch faces.

When im testing them via run option on My Galaxy Watch 4 Classic 46mm
which is on the latest firmware. The name of watch face appears just fine during testing. But after being build and uploaded and published.

The watch face when you press uninstall or when you view in Galaxy Wearable app it has no label please see my screenshot. I have tried all possible ways by even reducing the labels to 5 alphabets by give smaller labels when building the watch face
but i have been unable to resolve this issue. If anyone can help it would be really great.

Thanks in Advance

Hi Osman,

We are looking into this but I don’t see anyone else responding saying they see the issure. Are you sure you added the Label in the project settings if so can you open a support request or provide more information?

Samsung Developer Relations

1 Like


i have created support request ticket added the screenshot and the issue explained.
I am 100 percent sure about entering the label during final building. I have even tried shortening the label to 6 letters but still this is happening after the watch face is published.

the label is correctly displayed on test builds.

@Osman it is still such an auxiliary question. Do you have any external theme installed on your phone, or is it on the stock theme? If you have one from the store, check how it will look in stock?
I am asking because I know there were such problems with displaying text on the added themes.

1 Like

Hi i didnt understand the question.

If you are asking about my phone connected to watch. It has yes sn external theme installed with Hex installer for theming. And my phone is not on default theme.

And if you are asking about watchfaces on my watch4classic i have watchfaces which i am debugging from watchfacestudio installed or other watchfaces that i have bought from playstore.

What is happening is that during testing my watchface shows correct labels in wearable app as well as on my watch4 classic on which im testing.

BUT when i have final watchface uploaded after building it in watchfacestudion v 1 .0.12 and also was happening on 1.0.11 that the watchfaces

AFTER PUBLICATION of watchface i have downloaded the same watchface and also reported by a user that theyhave no label or name.

Only thing wrong maybe which can be the cause im not sure which i think is that i usually remake new watchfaces on same wfs file

by making modifications and saving old one with new name. Close the previous and use the 1 with new name saved for the new watchface

@Osman in this case, try to make a new project clean, without using the old file. This will allow you to exclude one of the causes of the error.

I think this may be a bug, the WFS development team thinks it is user error but are looking into it.

If you don’t have a label in the project and run on device or upload to the store it will use the project name. I can duplicate that when run on device it uses the project name not what is put into the Label text box in the project setting.

Samsung Developer Relations

Thanks. I am in contact with Ron i have shared the wfs file for inspection . One more thing i would like to add that i have forgotten to mention is

I am using localization en US selected when building the watchface final version that is to be uploaded , can that be the issue ?

@Osman I also use US localization and don’t have this bug so that’s not the reason.

Today i checked a watchface which i made specially to check this issue fresh without old carry over of wfs file.
Brand new file from start.

The label was fine and not missing during tests.

I downloaded the watchface from playstore And again same thing blank label. Now im 100 percent sure its not due to my wfs . I believe it has something to do with fonts

And just to be sure, set a stock theme on your phone and check it out. Perhaps that is where the problem lies. All cases that could generate an error must be eliminated.

Well I sent link to the published watchface to Ron via the request ticket crospondence. He installed and tested the watchface and confirmed that there is no label and also shared the watchface was. It is still under investigation.

So that is probably not the phone. :slight_smile:

I just downloaded 1 watchface that had label issues as well. Now i see the label present.

What i did different while updating this watchface as far as i remember is i added all fonts again to the wfs inside the watchface and saved the wfs.

I have changed workspace folder 3 x times uptil now since first version .It seems to me that maybe after changing the workspace location all previous fonts used in watchfaces made in older version the fonts have also to be added again to wfs files.

I will try this again by adding fonts again to the ones having label issue and see if thats the case.

I am waiting for the solution with interest, because it is quite a strange mistake.

I just downloaded 1 watchface that had label issues as well. Now i see the label present.

Hmm, that is weird. I uninstalled and reinstalled Digital Basic 5 12h/24H and there is no label. Your Digital Basic 5B does have a label. Do you know what the difference could have been? Try updating Digital Basic 5 12h/24H and see if that fixes it. The WFS team wonders if you added the label after you built the file but before you uploaded it.

I will try this again by adding fonts again to the ones having label issue and see if thats the case.

The fonts should not have any reason for the Label to not appear but what the heck give it a try.

Samsung Developer Relations

Well this bug has been giving me OCD for many days it fails to resolve . It has happened again on the newest watch face i made 2 days ago :alien: :crazy_face:

  1. No carry forward wfs file
  2. font used copied in /workspace folder.
  3. font properly added.
  4. Proper label name same as the watch face name.

it has happened so much now that i have started to give a … lol

You have to install the fonts in Windows. Usually just double tapping on the fonts file will install them. You need that in addition to putting the fonts in a path that the WFS can use i.e. workspace or a subfolder of workspace.

The proper label will not show when run on watch that is something that is used when it is installed from Play Store. I’m checking to see if this is a bug or not, I can duplicate this with v1.0.12 I don’t know if it works correctly with 1.0.3 I never looked for it there.

Samsung Developer Relations

1 Like

Well im using latest watchfacestudio and i install fonts on windows 10 before i import them also place them in workspace folder.

But still this blank label is happening on every new watchface after getting published on playstore Ron.

I think there was a misunderstanding because we had two discussions going. Fonts has nothing to do with the label.

I’ll contact you about this.


1 Like

I think Ron , i have finally cracked the mystery of no lablels after watchface published.:stuck_out_tongue:

I was using android studio and i found out it gives tip to rename the watchface 1st word with capital like D in Digitalbasic 8 in this text for lablel below

com.watchfacestudio.Digitalbasic8 Correct
com.watchfacestudio.digitalbasic8 Wrong

sO I also made 1st Alphabet of Label while generating aab from wfs capital and this time i have just checked label is displayed correctly after upload to playstore.

Im going to further check this when i next get a watchface published.

because if this is the case i cannot rename those watchfaces which have been already published on playstore and correct them now.