WFS 1.3.13 doesn't recognise GW5 Pro

Hi all, I need some help with the Watch Face Studio on my main PC…
Basically it no longer recognizes my Watch 5 Pro: I’ve tried everything, from simply entering the IP to the recommended adb connect method… Nothing.

With adb connect it actually connects it, but it is not recognized by the program in any case.

The program is also installed on my husband’s pc and on my netbook, and there are no problems with those… but I’d like to go back to work on my “flagship” pc.

I’ve already tried uninstalling the program and cleaning the registry from the related entries before reinstalling, but even that turned out to be a non-solution.

Even putting back 1.3.12, despite the well-known date change problem, has not given results.

Do you have any suggestions, before I have a fit of formatting it in acid?

Thank you all so much!

1 Like

Welcome to this forum.

Did you try the following steps to connect your watch to PC using debug over Wi-Fi:

  1. Connect the watch and laptop to the same Wi-Fi network.
  2. Turn on the development mode in the watch (Settings->About watch->Software->Software version (tap 5 times on software version))
    ** After tapping 5 times on the software version, a text appears that development mode is on
  3. Turn on ADB debugging mode for the watch (Settings->Developer options->ADB debugging).
  4. Turn Debug over Wi-Fi
    **If the IP address shows in the ADB Debugging → Wi-Fi, then it is connected, it always takes a minute for the connection and says unavailable until it connects.
  5. Click the run-on device button in Watch Face Studio.
  6. If your watch does not show on the list put the IP address (watch IP address) in the connection box.
  7. Select the watch and deploy your watch face.
    If you tried these steps could you share on which step you face the problem?

Hi Boshra, first of all thanks for your reply.
Until before the change of year problem I was working fluently with the program without any problems.
Some of my creations are also on play store, ergo I know debug mode and I know how to activate it.
The problem is that when you have to enter the IP, then it is not listed.
Since this problem does not occur on the other computers in the house (as mentioned before, everything works perfectly on my husband’s and on my laptop, but I use the graphics software on my main, more powerful PC, which is the only that has this problem) most likely the problem is NOT in the configuration of the smartwatch.

1 Like

I had to do the IP address again as it had gone from WFS . I am not sure if it changed but got the address from the watch GW4 . Everything works fine again .

First is the Slap your forehead answer. You have your ethernet cable plugged in so the computer isn’t connected to the wifi… we assume that isn’t the reason.

Second is you rejected your computer one time when trying to connect.

In your watch settings
Developer Options
scroll past ADB debugging
select Revoke Debugging Authorizations

Restart your watch and computer
Turn on ADB debugging and WiFi connecting it should connect and show after a few minutes

Now when you run on Device and select the IP address your watch will ask you to allow it and have the option to remember that computer.

If it isn’t one of those two there is a way to force it but I bet it is one of those two reasons.

Samsung Developer Relations

1 Like

Thank you Ron for your answer.
Just a thing… I’m not on LAN, but only WAN… so I haven’t ethernet cables.

These are the steps.
01: manual connection
02: allow debugging (always)
03: PC available on GW5 (artemis)
04: IP in WFS
05: Nothing found.


Maybe this will help.

  1. install ADB (Download SDK Platform Tools release notes | Android Developers)

  2. Add adb (platform tools folder) Path to system environment variables (If you don’t know how just google it)

  3. open wifi settings on your watch and remember watch IP address

  4. open cmd (command prompt) and write adb connect ‘your watch IP’ (adb connect

  5. check WFS - Your watch should be listed here

Edit: I believe WFS and adb are using port 5555, from your screenshot ‘34647’ is visible so maybe try:

adb connect

After you get no compatible devices hit scan again.

I often have to do that.

The only thing I can think of as Amoledwatchfaces said is that for some reason port 5555 is being used by another program on your laptop.

Samsung Developer Relations

Hi Ron,
port 5555 is ricognised when I do the manual adb connection… I think it’s not that the problem…


Since it works on other computers, I’m a bit stumped

You clearly know what you are doing try restarting your computer and watch, (restart so the caches are cleared).

Press and hold both watch buttons until it goes blank and it will reboot.

That is my only shot in the dark. It probably will force you to allow the device anew when you start debugging but you don’t need to re-pair or reconnect WiFi on the watch.

Launch ADB from the Watch not the computer.

Samsung Developer Relations

U have to uninstall windows and then installing it again. I had same problems with watch 4.

In fact this was the solution that, in my heart, I already knew… but that I kept as the last card to play… :sweat_smile:
I think the game will start soon.

Is Bluetooth turned on on your watch while trying to connect it to PC?

My GW4 won’t stay connected to WiFi unless I turn off Bluetooth first. Only then the WiFi connection stays stable and the WFS can recognize it without issues.

My process is the following:
Watch: turn off Bluetooth - turn on WiFi - connect to the same network as PC - tap on that network in the watch Settings and remember IP address
WFS: Run on Device - “+” - enter the same IP address from the WiFi Settings on watch

It’s a simple suggestion, but it might help.
Best of luck!

Just change windows. Best solution is windows 10. Need 30 min