WFS v1.0.11 NEW Version Connection Bug adb?

Hi anyone else having issue with the new version when I do Run On Device and hit scan or + I get the popup on watch to connect and the connection is fine as i can see this when I run below command However it never appears for me to select my watch in the Connected Devices panel.

C:\Program Files\WatchFaceStudio\tools\window>adb devices
List of devices attached device

So after trying everything I found if I ran the older software 1.0.3 version its shows the watch no problem and I can select and upload. I can see the versions are differnt from the folder C:\Program Files\WatchFaceStudio.103\tools\window.

1 Like

I have the same problem.

[Edit] I just tried it with v1.0.11 and had no issues - OOPs the computer I used had not been updated yet

There is a new version WFS 1.0.12 that has a fix.

Samsung Developer Relations

I am facing the exact same issue with version 1.0.12 as well.

I am doing the same thing of using the adb command to install.
adb install -t path_to_apk

Any idea how to get it working through the WFS?

yeah, I also facing same issue with 1.0.12, as a workaround, I am deploying the apk manually using adb install command (adb install path_to_apk)

Simple solution is to manually search for device ip in wfs. Then quit wfs & re-open.

Yes, that is what is working for me after an adb connect!
A reason? Certainly à bug, but with a so simple solution!

It is a cache issue.
So the fix is
Connect debug on Watch wait for it to connect a minute or so.
Build Project,
Run on device (it can’t find it)
Restart WFS
Run on device (it finds it).

It only happens after the initial launch after a shut down. It does not need it after that.

Agreed it is a pain but not worth a Fast Fix.

Samsung Developer Relations