What does this error mean?

I’m updating a previously published watch face with WFS v1.0.3, but got this message showed up at the end of build process.


i think, adb conflicts with another.

Only one watch is connected and Run on Device works fine, the error message only occurs at end of the build process.

Check your build log and see if it makes sense there.

Windows : C:\Users{User}\AppData\Roaming\watchfacestudio\dump\main
macOS : /Users/User Name/Library/Application Support/watchfacestudio/dump/main

Samsung Developer Relations

Am I the only one who is experiencing with this error? There is still no solution to it, I’ve uninstalled and reinstalled WFS and created a simple test project with nothing but a default digital clock in the middle, with all default settings and still got the same error.

Is your build file on a cloud drive? I think that is an issue, if it is try it on a local drive and see if it works.

Samsung Developer Relations

The workspace was on OneDrive, but so was previous WFS version and it worked without any issue.

I’ve uninstalled FWS, restarted computer, reinstalled it and set workspace to the default setting which is C:\Users\John\WatchFaceStudio. But same error persists, very frustrating.

This happens on two computers, it’s very strange that I’m the only person experiencing this.