Galaxt Watch Studio cannot connect to watch


I am using Galaxy Watch Studio V.2.0.0_beta for Windows. Unfortunately I can’t connect to my Galaxy S3 Classic by GWS. Developer mode : on
I entered correct IP address
Restarted my watch and computer
It doesn’t work.

Could you please help me? Thank you so much for your support.

Cem Erman

Hi @erm1580737243,
Try the following troubleshooting,

  1. Make sure again your PC and Watch are connected to the same network by checking their ip addresses, and the Watch has the debugging mode turned on.
  2. Go to the top-right corner on GWS interface and click Run On Device icon and enter the correct ip address of your watch and click OK.
  3. Keep a close look on your watch, a pop up will be shown to accept the RSA key and you have to accept it very quickly as it will stay for a few seconds. If you miss, it will never come back.
  4. After accepting the RSA key, your watch will be connected to GWS automatically.

N.B. Sometimes you need to do step 2 for several times until it can find your watch and also keep your watch awake at that moment. Also restarting your router helps GWS to find your watch.

If those steps does not resolve your problem or you don’t see the RSA key pop up, reboot your watch by holding the home key button pressed for about 15 seconds or until it says rebooting. After that try the steps above again and it will solve your problem eventually.


Along with with what Azad said be sure Bluetooth is off or your phone is set in WiFi always on. Be sure there are no firewalls in your computer blocking it.

If you have firewalls you can connect by USB to phone then Bluetooth watch we can help with that.

Samsung Developer Program

Hello Azad and Ron,

I more or less design watchface for 2 years. All of settings you said is ok. I checked all settings you said again and I couldn’t see any problem. This morning, I uninstalled GWS and installed 1.8.1 however I had same problem and then I unistalled 1.8.1 and installed GWS 2.0.0 again then both my compouter and my watch restart and the problem has gone. I couldn’t understand what the problem is.

Sorry for taking your time. Thank you so much for your interest and supports.

Cem Erman

1 Like

I’m glad you got it restored.

GWD/GWS requires a port for connecting to the Watch and it may be that some other app was trying to use that port. Installing and uninstalling 1.8.1 may have reset the port. That is my guess for now.

Thanks for letting us know,