All profiles corrupted (or Watch) after a trial to extend the author certificate?


I can no longer work with Tizen Studio since last Sunday after trying to extend my author’s certificate.
I applied step by step what is explained here

before starting a long project (my previous certificate was not yet expired, but I have had certificate problems in the past):
Hope this link works for most of people, but not for me!

After creating my new author certificate (built from the old one) a first attempt to download my development on my watch showed me Error-12.

Since that trial, no more profile works (see attached photo), I tried to start from scratch (factory reset of my watch, new author certificate created, new distributor certificate created, new project created for upload test), nothing works: Error-12, Error-12 and Error-12.

My previous profile which worked for several months does not work any more, no new profile works (maybe 10 or 15 attempts without success, fortunately that Samsung validates my repeated requests, and I remember my login and passwd so well I connect to my samsung account!)
I opened a ticket last tuesday, sent several screenshot, but I still wait for an answer.

I hope my watch has not been corrupted by Tizen Studio :disappointed:
I’m desperate!
Can someone help me please?


1 Like

Maybe there is some issue in last Tizen Studio but I doubt.

Make sure you have current date on your computer and watch. Creating distributor cert don’t forget to put duid for your watch device otherwise your will be not able to transfer package on that watch.

Finally you can check your signed package on RTL device


I don’t know if it’s an issue, but after one week I finally found (alone) the solution, I created a new distributor certificate with only DUID of my Watch, and without the DUID of emulators…

I seem to remember that 2 years ago when I connected my watch for the first time, it was necessary to put the DUID of the emulators in the distributor’s certificate to be able to use them (but I am not sure …).

I had sth like that about 3 years ago. I forgot about that. After adding 2 DUIDs: for watch and mobile (Z2) I can’t transfer the package on the watch. It worked only for one DUID per cert in the same time.

I glad you was managing to resolve the issue.