Generating distributor/author certificate timeout ... again


With GWS v2.0.0 or 2.0.1, generating certificate both author or distributor invariably ends with a “timeout” message after signing the samsung account … I tried many times but always with the same result.

I’m on w10 with jre 1.8

Is anyone could help please ?

Best regards,

I am having the same issue, same specs. glad to know im not the only one, but i hope this is resolved too

I just saw someone with Tizen Studio has the same issue.

It looks like this is a store issue. I’ve seen it happen before. Usually it works after a couple days. However be sure you are not using Internet Explorer as the default browser and I’m not sure on FireFox either.

If this drags on for more than a couple days let me know and I’ll escalate the issue.

Samsung Developer Relations

1 Like

The certificate server has been returning 408 errors since at least Tuesday morning (in the UK), so at least 54 hours. I’ve tried going through both Galaxy Watch Studio and Tizen Studio to see if there’s any difference but no joy.

I was going to start my first proper project on Tizen this week as well!

I will escalate this issue with my contact for the Store Portal.

Samsung Developer Relations

I tried again today with the same result so unfortunately I can not download my projects on the watch …

I hope the pb will be corrected soon ;(

We have escalated this to the Seller Portal operations team and hope to get an ETA of when it will be fixed if it isn’t fixed the first of the week.

Samsung Developer Relations

When can we expect a solution? Will it be posted here or do we have to trial and error until it works again?

i am having same issue since a week

Same Issue as well, in Tizen Studio and Galaxy Watch Studio 2.0.0 and 2.0.1

Please fix!

Thank you!

It is starting to look like this is an issue with the Tizen Development team not the seller portal. It was escalated to them Friday.

I should be copied on any email and will post when I get a response.

Samsung Developer Program

it seems it is fixed for now

Yessss, it’s fixed ! Thanks a lot

Worked for some days. Now Author Certificate no longer accepted (no changes made!) - Generating a new one: TIMEOUT … it ist really unbelievable: Version 2.0.1 is unusable since October due to the AOD-Bug and 2.0.0 ist now also obviously unusable…

Apparently the fix only fixed the Distributor Certificates and not the Author Certificates.

You do not need to generate a new Author’s Certificate (and never should) did you back up the old one as instructed? If so you can create a new Distributor Certificate. The Author Certificate is only needed to build your watch face not run on device.

I reported this and since they know what the issue was hopefully they can fix it early Monday.

Samsung Developer Relations

1 Like

I wonder why it worked for at least one day!? Yes I do have a backup of the certificate.
Now it says Author Certificate not match [-11]. Therefore I wanted to generate a new one. With the timeout result. Should I simply copy back the old one and wait until it works again (if ever)?

Confirming that I have the same issue.

I don’t have a certificate at the moment so I’m unable to deploy my application on real hardware for testing.

Getting the time out myself in tizen studio when trying to generate an author signature. Any update on when this will be resolved?

I didn’t realize it was both Author and Distributor Certificates so only reported the Distributor certificate. Hope fully they will fix this quickly. I escalated this over the weekend and hope they fix it soon.

Samsung Developer Relations

unbelievable… Samsung… no words!