Android Permissions Bug (Maybe)

My watch face has a object with tap action to measure heart rate, but it recently stopped responding to touches after testing some new builds.

After some hair pulling trying to figure out what I broke, I’ve noticed that when deploying, it is no longer prompting me for the permissions to read vitals/heart rate data like it used to, hence I presume why it isn’t working.

I don’t know why this has happened, I’ve only made a few cosmetic changes to the watch face, but also recently upgraded to WFS 1.2.5, not sure if this is related?

I have tried removing the watch face completely and reinstalling, and I have tried setting the heart rate check interval in the project settings ( though I am sure I have only used a button without this before and it worked), but I can’t make it request the permissions and hence can’t test or use my HR functions. Help.

Ok, I figured it out, will leave the solution here in case anyone else gets caught out by this.

For debugging purposes, I had removed the text with the [HR] tag in it. It looks like if you don’t use the [HR] tag anywhere on your watch face, it won’t request permissions. I did still have fields with [HR_IS_MEASURING] in use and a button with Measure Heart Rate action on it, but these alone do not seem to get flagged to request Vital Sign Permissions like [HR] tag does.

Hello, thank you for your interest.
If your project doesn’t include the [HR] or [HR_Z] tag, it means that there is no way to present the customer’s HR value on the watch face, so permission request or actions for HR measurement do not work. It is for an optimization.