Battery level stays at 100% until after watch restart

I’m not sure if this is the right place to post this, if not could you give me a pointer?

Hi there!

I’m developing a watchface with the battery percentage in text (using the tag), but sometimes it hangs at 100 even though the watch is not fully charged. After a reboot it returns to normal and stays up to date with the actual battery level. One of my testers also reported this and we both have a Google Pixel Watch 2.

Does anyone else have this problem and/or a workaround?

Welcome to this forum. I think you have come to the right forum for your problem. Here designers are very friendly and helpful.

Can you share a sample project where the issue occurs? This may help to test and help you. Or you can share the tag you used.

Are u using password /pin on the watch?

GitHub - JonathanBout/programmer-watchface is my face
The tag I use is ([BATT_PER])

Yes I am but it just happens after installing when I am ‘logged in’

Hi, does it happen with factory native face?

No. It seems to happen every time the face is updated or installed from the play store. When running from WFS it works properly.

Edit: It happens when I switch face theme as well…

Hi, only wfs designed watch faces, when i say native means other faces u download from google or the already install faces? Just to confirm.
If only wfs design watch faces. Next is to try other developers wfs watch faces?

So to see if its only yours or its because of WFS.

So far nvr experience your issue. But i am on gw 5 pro.
(I have tried other developers watch faces on google)

So wondering is it watch specific issue?

I don’t have any other 3rd party watch faces installe and I don’t know which are made with WFS

Hi, go try install 3rd party watch then.

We need to isolated the issues

Hi u mentioned only faces from playstore? Can you post the one having issues? The link?

And as i say is only your own design face have issue or its across others…

If only yours then try other wfs version see if it helps because the tag looks fine.

If its multiple watch faces then its some other issues.

P.s does swaping watch face help or u must restart?
Meaning change face, then change back?

Thanks for sharing the information. I have checked your project with my Galaxy watch6, it works fine. I have tried with the tag in a new project, the tag is working as expected.

It could be your pixel watch issue.
I will suggest you submit a support request to get support from the Samsung Developers Technical Support team. If it’s a WFS issue, they may help.

If you create a support request share the sample project and description of the issue.

Hi. It’s Pixel Watch Declarative Watch Face renderer issue. It happens when you enter customization screen. Temporary workaround is to switch to another watch face and back. This issue is currently being worked on.



Thank you! That indeed solves it!
Can I track the progress of that somewhere?

Yes, escalated here: Watch Face Format; SourceType STEP_COUNT not working on Pixel Watch 2 [305477774] - Issue Tracker (

Applies to all STEPS, BATTERY and HEART_RATE tags.

1 Like