BUG: LONG TEXT complication / next event / AOD with latest GW4 update

You’re right, I got the same result this morning - empty “next event” indicator.

Yesterday the “short text” for Next event was showing correctly for me, but today it just said “None”, even though I have events in my calendar for today.
I then tried changing the complication to something else, then back to next event, and now the Next event area is completely empty, just like Matteo showed in image. I’ve added new events, no change.
I’m changing my previous post, can fully confirm this bug also.

The watch really feels dysfunctional now, with non-refreshing AOD and half-empty indicators… :sweat_smile:

The list of bugs gets longer:

I can’t duplicate any of this so I can’t report it as a bug.

I responded to the next event on Redit But I used Calendar and not Outlook it may be an Outlook bug.
It appears to me that you now have to give permission to allow Watch Face to Receive Data from complications. (I think it is because calendar is a companion app) If it didn’t pop up when tap on the complication go to Settings → Apps → Permissions and find the watch face and see if it is allowed there.

AOD for Watchmaker works different and I think that is broke in the update. I can’t duplicate that at all with a WFS built. The only thing I can think of is that some non-conforming AoD’s have seconds and those no longer update. Ambient Mode does not support seconds.

I have 3 of Matteo’s and a couple other sellers and my watch face and all work and update AoD but only on the minute, as they should.

Samsung Developer Relations

Hi Ron,

please check you have the latest version on GW4: R875FXXU1EVA8.

I don’t understand why it works for you, today I replied to about 30 emails for the same issues after the last GW4 update.

There are also posts on various international sites / blogs coming out about the same problem … There is definitely something wrong.

I have done countless tests and the complication “LONG TEXT” and AOD do not work correctly.
I also use Calendar and not Outlook.

Obviously we have checked everything: permissions etc. But it still doesn’t work.


I just got a new one R890XXU1EVA8 let me try again.


Hi Ron,
AOD may work fine for the first 3-4 minutes. Then it stucks. It may wake up in 10-15 minutes sporadically and may not at all.

Thanks Maxxmalkinof and Matteo!!

Now I can duplicate the AoD issue.

However the Next Event seems to work on Matteo’s watch faces after I agreed to permissions


1 Like

Hi Ron, please try these steps now.

Hi Amoled,

Did you set the permissions on the watch faces to allow complications data? What calendar are you using?


Here’s how to get Event complication issue:

  1. Select Calendar in the complication settings
  2. Allow permission if you didn’t before
  3. Watch face complication is showing None if there’s no upcoming events
  4. Tap complication
  5. It will ask to open Calendar app on phone. I use Samsung Calendar (not Google, not Outlook)
  6. Make a new event. Watch face is still showing None, the complication tap zone is working and the event could be found in Calendar app on a watch.
  7. Switch to another WF and back to reload WF. The complication is blank now, even its tap zone doesn’t work.
  8. Now open Calendar app on phone. Delete the event. Watch face complication is showing None again and the tap zone is working again.
    Noticed 2-3 seconds freezing Calendar app UI or Back button action after a new event was created. Maybe it’s necessary to use a separate thread to sync phone and watch Calendar apps.
1 Like

All permissions allowed, stock Calendar app, in my case Google Calendar app but it uses same android calendar provider as any other calendar app. Please try steps above & pick calendar app as complications (green calendar icon).

A lot of users are currently reporting this issue.

1 Like

Darn jinxed again. Thanks for sticking with me on this.

Now it doesn’t work it only shows no upcoming events but when I add an event it doesn’t show the title any longer. It does work with the preinstalled watch faces.

I’ll report this as a WFS bug too.

Samsung Developer Relations


Any news yet on new update to fix everything they broke?

Anyone else noticing slow response too when unlocking watch after recieving a notification or returning to watchface?

1 Like

I’m not sure if this is a WFS issue or a recent update (firmware) issue. Complications work fine on other Wear OS versions and other devices. They also worked quite well before the last update.

Yes, I also noticed friezes / slow watch face after the last update.
There is also a problem with AOD

This issue was caused by Firmware update. Watch Face Studio team has already reported it to the firmware development team and they are checking this issue.

Since it’s firmware related issue, so it will take time to resolve this issue. Hopefully, this issue will be fixed in the next firmware update. If we get any update about the next release, we will let you know.

Your patience and cooperation are highly appreciated.


1 Like

Hopefully the new update or HOTFIX will be released soon.

Personally, I am receiving several emails, negative feedbacks and refunds due to these issues.


Hello everyone, I also confirm these bugs. Every day, like Matteo, I receive more than 20 letters on the topic of AOD not working and event complications, I hope and I am sure that the Samsung development team will help us soon and fix it in an update.
I’ve also noticed from social media that users are already fully aware that these issues are caused by the latest update. I really want to decide this as soon as possible, here is the topic on XDA https://www.xda-developers.com/galaxy-watch-4-update-breaking-watch-faces/

It is all over social media, the update didn’t just affect Watch Face Studio created apps it got everything but the preinstalled watch faces on all devices. The Wear OS Powered by Samsung team is aware of it.

Samsung Developer Relations


Definitely a FW bug.
I got the update today and my GW4 no longer works as it should. Time is no longer updated in AO mode, watch turns on regulary without wanting it to.
Power consumtion is higher.

Is there any way to install tje old FW???
With this FW the watch is no better than cheap products.

If I would make such a mess in SAP I would quickly get rid of my customers.

1 Like