Build Error Help me

Hi all, I’m having an error that is unnerving me. I state that I have already debugged on my galaxy watch active 2, and I have the author and distributor certificate issued to me a few minutes ago.
The problem is that when I try to insert the watch faces created I get this message “Resource are not found, please check the resource is available with your gwd project” then a long error message, can you help me by explaining what needs to be done, I’m in the first steps, Thanks a lot ,:slight_smile:

I think you are using GWS 2.0.1 it is buggy and was only meant to be used for Mac users.
If you can download GWS 2.0 (on the same page a little Previous version arrow reveals it).

To be more specific with GWS 2.0.1 it lets you create an AOD but then forgets it when you reload the project very annoying. That AOD is the resource that was missing. When you open the same gwd file with GWS 2.0.0 it will appear.

If that isn’t it I’ll be back Monday and can help more but this is a pretty frequent issue.

If it is it but you are on a Mac I can help you so it isn’t as painful.

Samsung Developer Relations

Hi Ron, and thank you, I had already tried to install the previous version (2.0.0), but when I click “Build” it gives me a button block, which, if clicked once again, crashes GWS telling me an unknown error I don’t know what to do, I’ve been trying to solve it since this morning

Just to be sure you did restart (not just shut down and start) to clear the cache after uninstalling GWS 2.0.1 and then installing GWS 2.0.0 if you didn’t uninstall everything reboot and install again.

Create a new Distributor Certificate I think there has been issues with that when you go back a version for some users.

If that isn’t it then.
Close GWS
go to C:\Program Files\Galaxy Watch Studio
In that folder is a file eclipsec.exe
That will generate a command prompt log copy and paste that into a text editor.

If you can’t spot the error redact any personal information and upload it here.

I’ll check back on this in a couple hours.

Samsung Developer Relations

Here’s what I did:

  • Uninstalled any version of GWS with the two certificates.
  • Installed version 2.0.0
  • Restarted the PC
  • When generating the author certificate the screen “hangs” not generating it at the moment but in default, probably corrupting it, as soon as I try to insert the watchfaces I get the second error as shown in the screen.

  • Unfortunately the situation repeats itself, I always get that error when I close the application.

I really don’t know what to do, I previously installed an even older version but nothing.
I don’t think it’s about the java version.

But then what can it be, I really tried everything, more than reinstalling version 2.0.0.
I’ve seen others who had the same problem as me, but didn’t solve it by renaming the hidden folder whose name I don’t remember, or two files with the same name which can create internal conflicts.

GWS 2.0.0 is pretty reliable. You could have kept the previous Author’s certificate you are supposed to keep a duplicate but it isn’t a big deal for you as you aren’t publishing in the store.

I think the error is with the Seller Portal on creating the Author’s certificate that happens every so often especially on the weekend when no one is there to reset the servers.

However, you do have GWS up and running or you wouldn’t get this far. If you can’t restore your Authors certificate wait until Monday and try again.

If you can just restore the Author’s certificate then use it and try to generate a new Distributor Certificate.

Best of Luck,
Samsung Developer Relations

All right, thank you very much, I’ll wait for Monday to redo the author’s certificate. that’s the problem, as soon as I press build it doesn’t go ahead, and if I risk it it closes everything giving me the error message on the screen, I’ll wait, thanks a lot for your availability, we’ll update on Monday :slight_smile:

I got the same issue. Did all the actions you did, tried GWS 2.0. Nothing works. Really sad about this as I was looking up to using my custom watch face. On GWS 2.1 I get an error but on GWS 2.0 it just crashes.

You can use GWS 2.0.1 on your Mac. The issue is that when you close GWS it does not reload the AOD but since it is there it does not create a default one. AOD is required for Tizen 4 watches so it gives a build error. The work around is after you create an AOD select all and save as custom complication. Or if you really don’t care about an AOD just create a simple digital clock every time.

There is a work around for GWS 2.0.0 by one of the Mac users here. You’d have to search for it here in the Galaxy Watch Studio for Tizen forum as it is pretty old but it worked and does not forget to load the previous AOD.

Hope this helps,

Samsung Developer Relations