G3 connection issue

Hi everybody! I’m trying to connect my G3 to GWS but with no results…
SW mac features: mac osx Big sur
I tried everything: debug on, wifi connection, BT connection, developer options on, reboot, and so on.
Now, is it a mac problem? Does anybody with Big Sur succeded in connecting G3 watch?
Is it possible that I need an informatic engineer to connect my damned watch?
Thanx

I sympathize with you since it is nothing you did wrong.

It is not you this is a known issue from Catalina time and I don’t think they addressed it in the latest update. You need to use the SDB from Tizen Studio. You can download that and get the SDB from it or you can create a support request and they will send you the file.

If you wish to go ahead and download and install Tizen Studio here is how to do it.

install Tizen studio 4.x.x and note where it installs to.
Open the location of Tizen Studio “tizen-studio” folder.
Open the “tools” folder within this folder.
Note the “sdb” program
Now find your GalaxyWatchDesigner in the MacOS Applications folder.
Right click on the file and choose “Show package contents”
Open the “tizen” folder
Open the “tools” folder
Drag the Tizen Studio sdb version of the file and drop in in the tools folder of the package tools folder overwriting the other sdb file.
Close the package
Now you run the designer, it will connect without the sdb error.
Keep a copy of this good sdb file in a safe place just in case you need to do this again after the next update.

Ok, thanx
I tried right now to install Tizen Studio but of course I could not complete due the “malware” block of mac os (even if I have already allowed Tizen)…
So I requested the SDB to support. Now I wait…

Hi @r.liechty_SDP , I received the SDB and after few trials, I succedeed! But unfortunately I’m again stuck on building the project due to “resource not found” (see attach). I’ve already checked the aod (mine and default) and I did not use any external resource (the test watch uses only a black background and the system hour with tizen font).
java version “17.0.1”
Could you kindly help me again? :slight_smile:
thanx


Schermata 2022-04-07 alle 13.54.59

I think it is that version of Java that is an issue. I saw a topic where someone said they had to go back to an older version.

However, with Windows that Build error message shows in GWS 2.0.1 for no AOD because it doesn’t load the AOD.

This thread has how to get GWS 2.0.0 to work on Big Sur he uses Java 13.0.2 for it.

There is other information after the solution in that thread so read it fully.

Hope that helps,

Ron
Samsung Developer Relations