Cannot select samsung certification

I cannot access samsung certificate extension.

I already installed it. But Tizen certificate manager doesn’t show selection screen.

I’m using Tizen Studio latest version on OSX.

Did you enable it in the package manager settings? It doesn’t seem to be mentioned in the documentation.
click on the settings Icon and then expand the extension SDK arrow. Make sure the Certificate and Wearable extensions are enabled.

Ron
Samsung Developer Program

Thanks for reply.

They are all enabled.

Here are screenshots for this situation.


certificate manager doesn’t suggest any selection of between Tizen certificate and Samsung Certificate.
Just only Tizen certificate.

Know what… I couldn’t do it either !!!

But I’m a pit bull and I don’t give up so after an hour or so. I uninstalled Samsung Certificate extension.
Tried to reinstall and it wouldn’t let me unsuccessful every time.
Closed Certificate Manager and re-opened it and now I could reinstall the Samsung Certificate manager and it works as described
click on the large + by the trash can and it gave me the choice of Tizen or Samsung Certificates like in the Documentation.

At least I didn’t have to reinstall the entire Tizen Studio.

Let me know if you have similar success.

Ron

Thanks for reply.

Sadly, I tried to reinstall Samsung Certificate extension , and there is no changes.

I also tried to reinstall tizen studio, but it also no changes.

My mac osx version is 10.15.6. Does it affect to this situation?

Maybe, I should copy of Samsung Certification file from window and import it to mac.

Did you reboot after updating the distributor certificate. Just turning off and turning back on does not always clear the caches.

I know there was a bad link to the distributor certificate in January but as far as I know that was fixed. I’ll check with our Mac/Tizen user in support and see if he has the same issue.

I know you can transfer the author certificate but I never tried it with the distributor certificate. I’d give it a shot.

Ron
Samsung Developer Program

Thanks for reply.

I found the reason.

I was use case sensitive file system. That was the reason.

Samsung certificate extension installed with name of “Certification-manager.app”, and local was “certification-manager.app”. So Tizen Certificate Manager couldn’t find extension.

I reinstall whole system with case insensitive file system, and all problems are gone.

Thanks to your struggles.

I hope others would be fix easy with this.

I would never had thought of that !!! I will note it.

Ron
Samsung Developer Program