Cannot send Watchface to my Watch Samsung Gear S3

Cannot send Watchface to my Watch Samsung Gear S3.
Get error messages when sending watchface to my watch.

What is going on here, or am I doing something wrong?

It is timing out because you did not accept the RSA Encryption key

You must have acknowledged the RSA key screen on the watch (allows for data transfer between the watch and your PC). If you missed this screen or don’t remember if you acknowledged it, disable Bluetooth, restart (power off then power on) the watch, and, after the message that shows your watch has reconnected to the network disappears, wait 30 - 60 seconds, then try connecting again. Keep your watch nearby and active as the RSA key screen displays for only a few seconds. You may need to repeat these steps (increasing the wait time after Wi-Fi has connected) to get to and acknowledge the RSA key screen.

If this simple step doesn’t work then let us know there are more drastic steps to take.

Samsung Developer Relations

I have tried the above,
So turned off Bluethoot of the watch and turned the watch off and on.
( Bluethoot is turned off ).
Tried with the program , transferring the watchface to the watch,
but get the same message.
The “runner” of transfer goes up to 60 %,
When it “wants” to install, it goes up to 65% and then I get the message (see above) about what went wrong.
Kind regards,

If you get to 60% then it is not a connection issue or the RSA issue.
A partial install is indicative of a bad image fonts or the OPR is too large.

If your AOD shows over 10% even if it is under the 13% it can be too much for the watch.
If you have any Adobe style true type fonts they will not load.
A corrupted image will not load.

The .gwd file is a .zip file make a copy of it and then rename the copy to .zip it or open it with an extracting app. Look at all the resources to see if any of them are corrupt.

Hope that helps,

Samsung Developer Relations

This is the error message , seems to be with a certificate
error, to do with.
How can I fix that and/or how do I get this certificate?

You can’t build without having an Author and Distributor Certificate. So error 12 is one of two things
You updated operating system and your certificate needs to be recreated or in this case you need to accept the RSA Encryption Key in order to decode the certificate.

Restart your watch by holding down the power off button for about 15 seconds until it says restarting.
Restart your computer to clear any caches (don’t just turn off an on).

make sure your watch has debugging and developer options enabled
set your watch face to a factory installed watch face (this helps keep the RSA Acceptance show longer)
Not run on device from GWS
Keep your watch active and watch it like a hawk
A dialog will come up to accept the RSA Encryption key it will have don’t show again but it won’t show again no matter if that is checked or not. OK it
The watch face should then transfer to your watch.

Samsung Developer Relations