Unable to install Watch face on smartwatch

Yesterday I installed Galaxy Watch Studio and created a simple Watch Face, just to see how it would look on my Galaxy Watch Active2. I’ve had a few errors which I fixed (AOD issues in 2.0.1) but now that everything was looking alright, I keep getting this over and over again. I can’t find a way to get this fixed.

I’m using Windows 11, if that matters.

Thanks to anyone who helps!

If you just upgraded to Window 11 and haven’t tried to run on device before you need to create a new Distributor Certificate.

If you have successfully connected to the watch and created a distributor certificate the error is because you didn’t OK the RSA Encryption Key. You need to do that the first time you try to sideload an watch face from computer to watch. (or is the watch or computer have a major update).

A problem is if you don’t OK it the first time it pops up it doesn’t pop up after that to force it hold down the power button for 15 seconds until it says rebooting and then when you go to run on device observe the watch closely and the RSA will pop up. It happens quickly and doesn’t stay long so watch the watch closely…

see FAQ 23 for more information or I can help you if that doesn’t

Ron

1 Like

Thank you so much!

I did already accept the RSA Encryption Key, but I restarted my watch just to make sure and, after a restart, it just worked. I can finally now continue working on my watch face.

If I get into any trouble again, I’ll make a post.
Bye.

I haven’t ran GWS in a year or so but there used to be a bug where you had restart GWS after the first time trying to run on device. I’m not sure what version that was and I don’t think it affected everyone. It was weird I know.

Glad you are up and running.

Ron

I get a similar problem except I don’t get the warning message. Nothing happens.



This is a slap your forehead moment. :slight_smile:
SM-R920 is Galaxy Watch5 and that is based on Wear OS powered by Samsung and not a Tizen OS based watch.

If you want to design for it use Watch Face Studio instead of Galaxy Watch Studio
If you want to develop for it. Use Android Studio not Tizen Studio.

Ron
Samsung Developer Relations