Cant connect to Galaxy 4 watch over wifi debug

I believe I have followed all the guides.

  1. Watch is connected to WiFi, 5ghz, so is laptop. on same freq.
  2. Dev Options are turned on on the watch,
  3. phone is plugged into laptop, usb debugging turned on.
  4. Watch Face Studio is up and running using the demo.
  5. putting the IP address in the connection box did not change it at all.
  6. nothing found on the scan either.

What am I missing?

I tried this solution and it worked,

  1. Before starting Watch Face Studio, ensure all ADB processes are NOT running in task manager > details.
  2. Connect watch and laptop on the same Wi-Fi network.
  3. Turned on the development mode in the watch.
  4. ADB debugging turned on for the watch(Settings->Developer options->ADB debugging).
  5. Click the run on device button in Watch face studio.
  6. Put the IP address (watch IP address) in the connection box.
  7. Accept debugging prompt if you have not set it to always allow on watch.
  8. Watch will show up for selection.

You can see this thread for more details Galaxy Watch 4 Not Showing Connected Devices - #10 by evbashkina

There is a cache bug in the latest WFS
Connect as before and select run on device. select or enter the IP address
No Compatible devices pops up
Shut down WFS
Reopen it
Run on Device will now show your watch4
At some point you need to allow debugging again from a pop up on your watch.

This will happen every time you shut down your computer.

Samsung Developer Relations

Thanks, through trial and error, close and open, watching my watch, checking in ADB to make sure I can connect to the watch in port 5555

Hi Rackflot,

If you are like me, from now on you’ll wonder why was this so hard the first time.


Samsung Developer Relations