Help! Galaxy Watch 4 Not Showing Connected Devices

For two days I could not solve the problem in any way. I am stumped and have no more ideas. Any help needed.

  1. Computer and Galaxy Watch 4 - the same Wi-Fi
  2. Enabled ADB debugging and Wi-Fi debugging option.
  3. Pop-up window “Allow debugging” - “OK”
  4. Downloaded: “SDK Platform-Tools for Windows”. Executed the command: adb connect 192.168.31.203:5555

I don’t see galaxy watch4 in the device list


I was able to get it to work using your steps but one time it just didn’t seem to communicate, so I did (using your ip address as an example):

adb disconnect 192.168.31.203:5555

then I did

adb connect 192.168.31.203:5555

and I got it back. Make sure you keep an eye on your watch to click ok when it asks for debugging.

Also, make sure you see the ip address on your watch so that you are successfully connected to wifi.

Same Problem here, I did not have to do any of that this is all I did .you have to Reboot the watch ,put your watch on the charger, Turn on WIFI, Auto is fine, Then goto settings > Network
and connect to into your network make sure you check that its connected to your system network, get the ip address of the watch.

Run studio I would close it and reboot.
Anyway Bring up run on device, Scan or ip address.

if done this way you should get a notice as to debug or not.

Gary

I did everything that was advised to me, but it did not bring the expected result.

I reset default settings. After loading, I repeated all the steps from the very beginning. This also did not bring the expected result. WFS still can’t see my watch.

Is the watch on the charger? If its not on the charger WIFI will disconnect. you must then go to setting network and click your router you have to do this to get the ip address.

Gary

Yes. Watch on charger

ok good, did you swipe down and turn on WIFI to auto?

Yes, WI FI is on.
When I launch SDK Tools from the command line and enter the “adb connect 192.168.31.203:5555” command, the “Allow Debugging” popup appears - I say “OK”.

And even after that, I don’t see galaxy watch4 in the device list

And why are you using SDK tools its not needed.

That is what you want to happened, But you need to use watch face studio to do the same thing . If you use SDK first , it will connect to your watch, so watch face studio will never see it. So do not use SDK.

Gary

In a neighboring topic, this solution helped, but not in my case (Galaxy Watch 4 Not Showing Connected Devices) .

It is also present in the debugging guide: Debug a Wear OS app  |  Android Developers

Your so close Roman.

Gary

UPD: I have another laptop. I installed WFS on it and it connects to my chats without any problems.
There might be a problem with my computer, but I don’t know how to solve it.