Galaxy Watch 4 Not Showing Connected Devices

Galaxy Watch 4 Not Showing Connected Device

  • Computer and Galaxy Watch 4 Same WiFi
  1. Try Connect Galaxy Watch 4

  2. Connect Success On Galaxy Watch 4 But Not Showing WatchFaceStudio
    image

for you have to connect with your mobile just change wifi setting go through manual or forget password click to the forget then try to reconnect.

  1. reconnect Wifi With DHCP > Not Showing WatchFaceStudio
  2. reconnect Wifi With Static IP > Not Showing WatchFaceStudio

Did you turn off Bluetooth on watch, I rebooted pc and watch after setting debug options and entered IP and it connected first time I got a prompt on watch to enable.

Did you check all the developer menu settings are correct ?

I enabled debug over wifi and adb debugging with the small blue circle to the right.

Now it connects without me doing anything after build and Run on Device

Solved

  1. Install android adb and unzip

  2. Open CMD and go to the unzipped Directory

  3. Enter adb connect command : adb connect Watch Wifi Address:5555
    ex) adb connect 192.168.219.109:5555

  4. Now see the watch4 in the list.

1 Like

I’m having the same issue with both a Watch 4 and Watch 4 Classic. I tried everything in this thread and can’t get either to show up in Connected Devices. Strangely, before I got either of these devices, I was able to connect to a Wear OS device. Hope someone can help.

I have tried everything as well and I just can’t get it to connect. I have the new Galaxy Watch 4 Classic. I did the reboots, made sure debugging was turned on (note: I was able to get the developer options turned on, but not by clicking on the build number because I couldn’t find it. I clicked on the software version multiple times and that was how I got it enabled). I have turned off bluetooth, confirmed my wifi was actually working on the phone without bluetooth. I tried the adb technique that [gwanhyun] suggested and produced the same results from the command line, but still no connection. :frowning:

Edit: I rebooted my computer again to reset the command line abd. One thing I didn’t catch was my watch had asked if I wanted to go into debug mode and I didn’t see it the first time to click okay. I can now see the device, but unfortunately I get a “Build Fail” notice. So I’m a little further along, but “Build Fail” is not much to go on.

Edit 2: Mystery solved on Build Fail. I had a transparent image to do a reveal using “change image” and the transparent image was missing. Note: I did turn bluetooth back on and I was still able to Run on Device through the wifi.

Thank you very much, worked like a charm.

There was no way to connect the clock until I see your post

Hello! My wifi debug watch does not connect to the studio. The IP address is not displayed on the watch.

Hello,
I tried this solution … it worked for me right away …
How to connect Watch Face Studio to Samsung Galaxy Watch 4

So far the only way I have been able to get my Galaxy Watch 4 Classic to connect and show up in the list is to do the following. I already have adb installed for my android phone which is needed to make the adb connect command. Adb debugging over wifi enabled on the watch.

  1. Before starting Watch Face Studio, ensure all adb processes are NOT running in task manager > details.
  2. Open Watch Face Studio as administrator (without I received a java error when hitting run on device) and open your project
  3. Click the run on device button in Watch face studio
  4. Open command prompt and connect to your watch. Adb connect 10.0.0.2 (replace for your IP)
  5. Accept debugging prompt if you have not set it to always allow on watch
  6. Watch shows up for selection