Cant debug wearable after OS

I am struggling for quite a time with a problem I can not find a solution to.
Since the last OS update to TIzen each time I need to upload .tpk and debug my watch I get this message box error from the visual studio:

Unable to start debugging. Unable to establish a connection to clrdbg. Debug output may contain more information.
And the debug output:

"c:\program files (x86)\microsoft visual studio\2019\community\common7\ide\extensions\rxxk5ibd.jwv\NetCat.exe" exited with code 0 (0x0).
I have tried almost everything, switched from VS2017 to VS2019, reinstalled JAVA JDK, removed Visual studio tools for Tizen, and reinstalled it again and more actions that have yielded nothing, I am already starting to give up. I have quite a few apps in the store and I can not update and maintain them.

I would be grateful to anyone who would guide me on how to solve this problem.

Here are few links that describe the same problem, but in none of them was the solution found:

1 Like

Try to follow the following steps.

  1. Reset the watch
  2. Turn on Developer Mode
  3. Turn on Debugging
  4. Create a new certificate.
  5. Update the NuGet packages.

If still no luck then check if you can run the application without debugging mode. You can temporarily debug your application by printing log. Please let us know your findings.

I have the same issue here.
Do you have any luck?

I have the very same problem, I am using Vis Studio 2019 updated the latest version , updated all the tizen packages using package manager, rebooted my watch several times in debug mode and it is still not working. I keep running into problem with using Tizen. just terrible. please resolve this.

Any response from Samsung on this topic?

hellou Samsung, anyone?