Tizen .NET and debug in watch failed!

Hello

I’m building an app for smartwatch with Tizen .NET extension and try to debug on my watch Samsung Galaxy II , i have this issue when a start the app:

Someone have any idea that can be ?

SDB is Samsung Device Bridge and it is what connects your computer to your phone for debugging.

Did you follow the instructions here? for getting your certificates

And info for running on the Phone ?

Ron
Samsung Developer Program

@r.liechty_SDP thanks for you answer !

I follow the instruction to create the certicate and to debug app in my watch but doesn’t work.

Same error message

If you can connect to the device to generate a distributor certificate then the issue is not accepting the RSA Encryption key so you can transfer files… Keep trying to connect and keep your watch active and observe it a RSA Encryption message should appear. You can not transfer any content unless this is accepted. This is part of the latest privacy rules and regulations.

Ron
Samsung Developer Program

Yes i got the DUID’s ID from my watch but when a start to debug i continue receive this message.
Do you think that the problem have relationship with the Dev Enviroment ?

Now i tried to reinstall the SDK but the same error.

It’s a shame that Tizen doesn’t perform as well in Visual Studio

Our expert that uses Visual Studio is on personal time off for the holidays but it should work.

I’m pretty sure you can’t connect if there is an error in SDB it is not the debugger it is the bridge to the device and you connected to get the distributor certificate.

Open the Tizen Studio package manager and make sure that you have the Wearable Extension installed and that it is turned on in the configurations (gear settings icon).

On your watch tap on the About Watch -> Software and scroll to Software version and tap on it 5 times to enable Developer Options also make sure the debugging is still on

Open Tizen Device Manager add the IP Address for the watch and try to connect to the watch. keep an eye on the watch you may need to enable the RSA Key. If the RSA Encryption key shows up that was the problem and it should work.

If the watch connects with the Device manager but stukk doesn’t connect by Visual Studio I’ll need the expert to help.

Ron
Samsung Developer Program

Thanks @r.liechty_SDP for your help !

Yesterday I tested inside the Tizen Studio an sample Native project and it works perfectly ! I deployed the app in my watch.

Probably something happen with Visual Studio.
I will continue looking the solution because I have knowledge only in C# language. If you have some idea about it please contact me .

Thanks :+1:

Hello @r.liechty_SDP !

I got new error message trying install the app by the Tizen console

Do you have any idea about this ?

My guess is that the RSA Encryption Key is not be accepted but that would not make sense if you were able to install another app previously. Once the computer is recognized you don’t need to accept it again unless the watch is reset for example paired to a new phone.

Make sure you are creating a compatible wearable app. Tizen 4 or older, your watch has debugging and developer Options enabled.

Ron
Samsung Developer Program

Same issue here, I can’t debug my app from visual studio.

What works:

  • Start without Debugging in Visual Studio
  • Running an app with or without debugging from Tizen Studio

I have:

  • Microsoft Visual Studio Community 2019 Version 16.8.3
  • Visual Studio Tools for Tizen 3.4.0.0
  • Every package updated in Package Manager
  • Certificate and watch set up to debugging

So to sum up: I can connect my watch to my PC, I can see it in Device Manager, the certificates are fine because I can run apps from both Tizen Studio and Visual Studio, I can debug an app from Tizen Studio but I can’t debug .net apps in Visual Studio because I get the same error as in the first post(“Unable to start program …/sdb.exe”).

How can I solve this issue?

@r.liechty_SDP could you please check my previous comment?