Debugger won't stop at breakpoint on emulator, but works on hardware

I seem to be experiencing the same problem as in this unanswered topic:

I’m 99% sure it’s caused by some configuration in Visual Studio 2019 because I can debug the same project on a colleague’s computer. But I’ve reset all the VS settings, imported his settings, uninstalled and reinstalled VS2019, uninstalled and reinstalled Tizen, and disabled “Synchronize Visual Studio settings across devices”, but the problem persists. I’m running Windows 10 Pro, and Tizen is installed in C:\Tizen, although it’s been that way since before the problem started.

I ran into this problem on my primary project last week, which had been hitting breakpoints just fine for several weeks, although it wouldn’t show me variable values unless they were declared as static. Perhaps my attempts to fix that problem caused this problem, but I’ve reset all VS settings to default.

To test, I generated a new, very simple project with Tizen Template Studio. All it does is display text on a single page. When I run the emulator, it will stop at breakpoints in the app setup code (Main.cs and App.xaml.cs), but won’t hit breakpoints in MainViewModel.cs.

Weirdly, it will hit all the breakpoints correctly when debugging on my Gear S3 Frontier watch.

Thanks for reading.
Any ideas?

I seem to have found the answer. After I wrote the post, I realized there is a Tizen-data folder next to the Tizen folder (for me, both in C:).

I deleted the entire Tizen-data folder, and then debugging worked again. There must have been something corrupted in the emulator itself.

You’ll need to create new emulators in Emulator Manager, and go back to Tools->Options->Tizen and re-enable “Sign the .tpk file…”

I hope this helps someone.