Can't run .wgt app on any TV, any network, any environment

Nor me, nor my colleagues can’t seem to run the app in Tizen Studio 5.1, neither Run as… neither Debug as… Some of my colleagues tried with newest version of TS available for download, we all had same result, and we all had same result trying several different apps that were running OK before.

We all followed the instructions, as we have always did before, at:

All the devices, certificates… configured OK, no errors.
We tried on several TVs. We tried on WiFi (same network of course) and cable.

I don’t have any more error info, besides this screenshot:

It has to be on WiFi no other way, Don’t have your computer plugged into the Ethernet even if that is the same network.

I have two ideas
One you are using Tizen Distributor Certificates and not Samsung’s Samsung Tizen Distributor Certificate.

The other is you didn’t set up Developer Mode on your TV correctly . Many people miss the step about restarting your TV after setting Developer Mode.

Samsung Developer Relations

Thanks for your quick reply!

As for the first thing I am using “Tizen Certificate Manager” (certificate icon in the menu toolbar) and I created my certificate, exactly as described in the link you provided.

As for the second thing, yes I setup Developer mode correctly. I do it every single time and I don’t skip a step (actually, I do it hundreds of times step by step by the book).


I asked around checked all my old notes and simply do not have a clue why something worked before doesn’t work now.
Unless it is a firewall or something the only other thing I know of is if there is an app using the port normally assigned for SDB.

I wish you luck and if this automagically works again let us know.

Samsung Developer Relations

I got same issue. What I did was to uninstall tizen studio (completely remove tizen-studio and tizen-studio-data) and install it again.
If you sill have issue, create a brand new Tizen project from a tamplate, and replace project contents with your project contents (files).
I’m using Windows, btw.
I believe Tizen studio based on eclipse and its sub systems seems to have an issue with the compiler, packaging, installer, etc… once awhile it need to start fresh. :frowning:

I managed to solve the issue, my java was too new and I had to deinstall it and install 1.8.0