CCW settings not working


first post here …

I’m designing a watch and wanted to switch the seconds to 60 rotations per minute on CCW when it switches to night mode.

It works perfectly in CW mode, which I use for daytime, but any setting that I put for CCW defaults to 1 rotation per minute (instead of 10, 20 , 30 60 … none work)

It displays perfectly in the app, but the issue happens when i push it to my Galaxy Watch (1st gen).

As anyone else seen this issue before ?

There are not seconds in AoD mode that is why it doesn’t work.

Samsung Developer Relations

I didn’t use to AoD mode when i built it.

The issue occurs with the “regular” display of 15 seconds.

I mentioned “Night mode” , but that’s only because I put the background and other things darker.

Thanks I understand now. It sounds like a bug.
Try changing the movement from normal to sweep or tension
Assuming that won’t work
Set Sync with
conditions > none
set the rotate to -([s] *5)

Let me know if that works it does in GWS 2.0.0

Samsung Developer Relations

Hi Ron,

when changing the movement from sweep to normal or tension, it will only “skip” the amount of seconds that i enter in the rotate field.

If I set “sync with” to conditions and none, that greys out most of the fields so I can’t set a rotate value.

When I leave it to “sync with seconds in minutes” and change the rotate value to a negative value, that will switch the rotation from cw to ccw and vice versa and change the speed of the rotation in the app as well , but it doesn’t change the speed of the rotation on the watch … still at 1 full rotation per minute, instead of 1 full rotation per second.

All tested on version 2.0.0

Yeah I see the issue once you go over 15 it doesn’t work the animations are 15 frames per second so I think that is the reason.

Samsung Developer Relations by the way I typed 5 instead of 6 in the setting above.

just odd that the same function works perfectly in cw but not ccw…

I tried -([s] *6) in the tag expression. That did not look faster than the default speed to me, and it seems to do a reset when it hits around the 3 seconds mark but it does starts from 60.

First off I had a brain freeze when I thought it may have something to do with Animation.

Second when I put it to sweep it works counterclockwise. But when I do a lot of the settings change so I have to redo it until 60 rotations and CWW and Sweep are all set

Did you try that? It works in the run window but I didn’t try it on my watch.


It always worked in the app. It’s only on my watch that I have the issue.

The animation does work cw on my watch though, just not ccw.

Sorry, I understand now, I don’t think there is any way to overcome if it is an OS issue. what watch do you have an what version of tizen software is it running. I’ll try to duplicate it.

Samsung Developer Relations

It’s a Galaxy Watch (SM-R805U) with Tizen Version and software version R805USQU1DVH1 SM-R805UZSVXAR