Certificate error [-12]

Hello,
i had this problem today while trying to load a new watchface on the smartwatch via wifi. until yesterday everything worked normally. I have already tried to restart PC and smartwatch and create a new RSA Key but the problem remains

Hi @dis1607296414,

If the older version of the watch face is already installed on your watch then uninstall it. Try to push a fresh project having one or two basic components and check whether the issue remains or not.

If the above doesn’t help, delete the distributor certificate from C:\Users\your_username\GearWatchDesigner\keystore. Then create a new distributor certificate for your watch and try to load the watch face afterwards.

Azad

Just to add to what Azad explained.

For others Galaxy Watch Active2 was updated to Tizen 5.5 and the to Tizen 5.5.0.1 and I believe both updates require a new Developer Certificate.

Ron
Samsung Developer Program

hi, thanks for the help. i’ve tryed to create a new certificate but the problem remains. It’s not a problem of tizen version, the watch is update to the v5.5 for some weeks and i never had this problem before. i’ve also tryed to upload a new watchface but nothing. the strange thing is that now when i press “run on device” and select the watch, GWS try to install the watchface while before it asked me if i want to rebuild the watchface and take me to the window “build project”.

This is what happened to me when I updated to Tizen 5.5.0.1 last week. First off it wouldn’t do anything then I realized that it had turned Developer Options and debugging off. Then it connected but I had to OK the RSA key. Then it needed a new Developer Certificate.
Finally, it connected but would not run and I had to rebuild the project with the new Certificate.

I never had to do that with a minor update before but I did with The Tizen 5.5.0.1 update. By the was with both GWS and Tizen Studio.

Ron
Samsung Developer Program

As your watch got updated to Tizen 5.5, I would recommend following Ron’s workaround for the connection issue.

Run On Device only asks to rebuild the project if the tpk package is out of date which means there is some modification in your design after the last build. It won’t ask to rebuild the project if there is no changes take place in your design rather it will attempt to install the watch face directly.

Azad