Connection impossible between studio and watch 4

hi everyone. this is my first post.
i’m french so please be nice with my mistakes.

i just had a new watch 4, and i found galaxy watch studio which seems very good. Unfortunatly, it is impossible for me to send my project to my watch…

-certificats are created
-watch 4 is connected to my phone by BT, and ‘ADB debugging’ and ‘BT debugging’ are activated (on the watch).
-my phone (S20+) have usb debugging activated and connected to my watch by bt and to my pc by USB.
-on the phone, sdboverbt: when i select my watch, i have a popup saying ‘selected device: watch 4’ BUT on the top i have “cannot connect BT”. socket and blutooth stay disabled, port and socket are 0.

In galaxy watch studio when i run ‘run on device’ i can see my phone but not my watch (because sdboverbt don’t succeed to connect to my watch, i guess).

i also tried by wifi, activating on my watch ‘debugging by wifi’ and entering its IP adresse in galaxy watch studio (with the ‘+’ button) but it does’nt work neither.

i’m sorry if the question has already been posted i did’nt find out. please help me i’m about to send it back I’m so degusted.

thank you very much


I’ve just been told that i am not using the good software. For my watch 4 it’s the watch face studio software.

I’m going to see it!