SPP connection or BT pairing problem on Watch3!

Hi all,

Is there anyone who owns a Watch3, successfully connected watch 3 with the sdboverbt application on your android phone?

I tried in many ways but every-time I get the following error,
connot connect BT: Galaxy Watch3 (XXXX), please check SPP connection or BT pairing

Please raise your voice if anyone have successfully done it.

TIA

Have you enabled debugging on both your watch and phone?

Yeah.
Indeed, my galaxy watch gets connected without any delay but not the watch3.
I just want to know if anyone have successfully connected with watch3.

Not the answer you were hoping for I assume but I’m also unable to get the Watch 3 connected with sdboverbt.

Getting the exact same error.
Debugging on Watch turned on,
Developer mode turned on.
Phone: USB Debugging enabled.

Not sure what to check or change, ideas are welcome.

Thanks, Jean

Hmmm… got it connected over Wifi.

Had to disable the desktop physical network connection to force it to use Wifi and entered the IP-address of the Watch 3 and it connected Ok.
Had to build package for Tizen 4 and generate Distribute Certificate but then it showed on the Watch 3.

Now I only need to find out how to properly design a watch face :wink:

1 Like

Yeah, I got it also connected using Wi-Fi but still unable to connect through SDBOverBT.