Constant connectivity problem

Difficult connecting app via wifi. I did it last night, but this morning it can’t find the watch! It has done this for years! I looked at trying to connect via BT but nothing says how to do that!

Is there any way to upload my watch face without a constant fight to get it connected??

What watch do you have? If it is Active2 or Watch3 (Tizen 5.5) you can’t connect via BT until there is a new firmware update. If it is an older Tizen version it should work fine.

Make sure you manually enter the IP address into the search. If you let GWS do the search it may start at an IP address higher than your watch is and never find it.

Some routers will switch IP addresses for a device always check that if it doesn’t connect quickly after you connected successfully. If you have seen this happen constantly then it may be your issue.

I’ve never had this issue but I’ve heard that some people have to turn off BT and not just have WiFi always on.

Ron
Samsung Developer Program

I’ve always had problems connecting. To the point it took hours if trying on wifi! If I didn’t like playing around with it so much I’d quit. I just downloaded the new 2.9 Studio and list mist of my complications on my watch faces from the older version. Frustrating. But if I can at least get them to my watch I can rebuild them.

This is so aggravating! The damn thing just will not connect. Did fine last night! BT nor Wifi. What a waste…

Did you mean
I just downloaded the new 2.0 Studio and lost most of my complications on my watch faces from the older version.

Starting with GWD 1.8 you could save custom complications. were you using that version. There was a bug in some versions older than that with grouping complications and update. That might be the problem.

more to come
Ron

Yes, 2.0. Typing on a phone.

I reopened the 2.0 and they are there now. No idea why it took awhile but it’s fine now. But I still can’t get connected via wifi or BT using the search or typing in the IP address. It just say No Deviuce found. Some spoke of an RSA approval (or something like that) appearing on the watch. I’ve never seen that. Is there a setting I’m missing?

That came in while I was typing. Make sure your ethernet cable is unplugged from your computer. On occasion the computer and watch will connect even if the computer is on ethernet but 9 times out of 10 it won’t. It sounds like this may by your issue. Even if you turn off the ethernet it seems if it is plugged in it screws things up.

Be sure both computer and watch are on the 2.4 Ghz band the computer isn’t on the 5.0 Ghz band.

It is frustrating I know first hand and I’m an expert. I had to update and pair 4 watches for a new phone and each time it removed all the old permissions and like a dummy I forgot to turn on debugging one time.

Ron
Samsung Developer Program

Sorry to whine. I appreciate your patience.

No ethernet, its a wifi connection. And, as I said, I came right up last night! No idea why it won’t now. I keep thinking of the definition of insanity - do do the same thing over and over expecting a different result! But that’s what I’ll do, I guess. Does everyone have this issue or is it just me? Literally this happens every time, to a greater or lesser degree.

If it is consistent then it is probably you. Once I put the IP address in (And select it) it pops up in seconds. First time is the only hard one.

Ron
Samsung Developer Program

Yeah, that figures. Is there any other way to connect? BT doesn’t seem to work either so maybe a wire through the phone and put the watch into the Wear app that way?

what watch do you have if it is Active2 or Watch3 it won’t do it via BT.

If this is older then you just didn’t OK the RSA Encryption Key

Ron

It’s an S3 Frontier from 2017. SM-R765T One UI 1.5 and Tizen 4.0.0.7

It’s an S3 Frontier from 2017. SM-R765T One UI 1.5 and Tizen 4.0.0.7

Got it! I was a dual channel wifi issue and I fixed it. Thanks for your help.