Can't connect Samsung Galaxy Watch to Tizen Device Manager

Hi, I am new to the forum. I’ve just purchased a Samsung Galaxy Watch and downloaded Tizen studio and developed my first app, using the tutorial. However, I get stuck at trying to connect my Galaxy Watch to Tizen Studio, using the Device Manager. I have tried countless times and combinations. My assumptions are that I need to be on the same WiFi (I have tried my home WiFi and directly to the laptop hotspot), debug mode needs to be ON, developer mode needs to be ON and Bluetooth need to be ON (I have tried ON and OFF).

When I toggle the connection switch, nothing happens for a variable period of time and occasionally an error message comes up saying: "image ; failed to connect to IP address. This could be because this remote device could be connected to another, and two other reasons.

I have tried disconnecting the connection from my watch to its paired phone.

Can you help,please ? As I find other people with similar issues on Stake Overflow.

You need your laptop connected to the same WiFi network as your Watch if you have a dual band modem connect both to the 2.4 Ghz band.
At least for me my llaptop can not be connected to Ethernet.
Sometimes you have to set your mobile as hotspot and connect both laptop and watch to that.

Bluetooth needs to be OFF or WiFi needs to be Always On
You can get your IP address from the watch connections settings for WiFi

When you first try to connect it may ask for you to accept and RSA Encryption Key you need to accept that. I can’t remember if it asks that when generating the Distributor certificate or later when you push the app to the watch.

Hope those helps

Ron
Samsung Developer Program

Ron,
Thanks for the reply. No joy unfortunately. I have stepped carefully through your notes and tried: using my phone as a hotspot and connecting both my laptop and watch to that. I’ve also tried ensuring that any WiFi is set to the 2.4GHz band when I have control over that.
I am stumped - any other ideas ?
Jon M

Hi,
What Galaxy Watch did you buy was it the new one or an older version. Is it an standalone watch or paired to a phone?

Go to Settings -> Gear info -> About device.
Tap on Software version 5 times. Then a confirmation pop up displayed once the Developer options is enabled.
Make sure Debugging is on in About Watch settings
Reboot your watch (by holding down the home key until it says rebooting)
Make sure Debugging is on after the restart
Important …Restart your Phone too
Restart your computer too.
Wait one full minute before attempting to connect.

Open Settings Connections make sure WiFi is always on.
Make sure that the watch is on your network I’ve seen reports of a watch connecting to a neighbors wifi.
Tap on the connection and then get the IP Address and write it down

If this is a personal WiFi access the modem and make sure that the watch and computer are both on that wifi channel.

Ron,
Thanks for trying to help me. I much appreciate it.
The watch is the old Galaxy Watch, although I only purchased it new recently. I bought the watch stand-alone, but I have connected it to my phone for alerts etc.

I can’t find Settings-> Gear Info. I have -> About Watch. The model number is a SM-R810.

I have previously enabled Developer Options, by tapping 5-times on Software.
I have also enabled de-bugging.

I’ll try re-starting everything, but I have re-booted my watch so many times now !!(;>)

Jon M

I’ve re-booted everything. Connected to 2.4GHz on my .mobile hotspot, for both my watch and the laptop. Still no joy

Sorry that was an old copy and paste.

I can connect to my watch later today and see if there is a step I am forgetting. I can’t connect while on VPN so I need to use my personal computer at the end of the work day.

Ron

My wife had the same problem. I took her watch to the service center and they set it up there somehow. I tried it myself, but it did not work.

They set it up to work with Tizen Studio or to Pair to the phone? I think your issue is a bit different than the original poster.

Oh and I think my brain wasn’t working earlier, the issue was accepting the RSA Encryption key. It is a different error on GWS where it is quite common.

Ron
Samsung Developer Program

On my laptop I had to enable file sharing before I could connect???

You may have to but I don’t think it is normal you will have to on your mobile. Normally you connect via WiFi and that may have a firewall that needs enabled. You cannot connect via Bluetooth from a pc to a watch only a mobile to a watch.

Ron
Samsung Developer Program

Hi Ron,
I am having the same problem and it is driving me crazy, short explainer:

I want to connect my Watch Active 2 to my Windows PC via Device Manager IDE.
Funnily enough it worked 2 days ago with out a problem, got the RSA key on the watch on the second attempt.
But I had to reset the watch since then and now I can not get the RSA Key question on the watch. I searched the net and i tried all of the following:

  • rebooting the watch multiple times, after turning debugging on.
  • having wifi on always on with bluetooth off
  • rebooting windows multiple times
  • disabling windows firewall completely
  • beeing on wifi or a hotspot from my android phone
  • resetting the watch multiple times

Can you help me with any more ideas?
or can i send you my logfiles so you can find out whats wrong?

Do following:

  1. Enable Debug mode in watch settings (if still disabled).
  2. Connect your computer and watch to the same Wifi network.
  3. Enter watch’s settings, find Connectivity/Wifi, find your Wifi network and connect your watch.
  4. Launch Tizen Studio, find an option Launch Remote Device Manager.
  5. On Launch Remote Device Manager popup click Scan. if found nothing click + icon and add manually your watch. Read IP address from watch settings/connectivites/wifi/networks//your_wifi_network

It always works for me.

If that usual way would work for me, I would not ask here for help.
Like I wrote above, all tried all of that in exactly that order.
I even tried to restart the server per cmd and so on.
Whatever I do I just do not get the RSA key popup on the watch

But thank you for trying to help

@r.liechty_SDP any ideas?

Hi,

If you did a reset you should be able to connect to your watch and get the new distributor certificate without having to accept the RSA Encryption key. If you can’t connect check to see if you still have the same IP address that often changes after a reset.

If you were able to generate a new distributor certificate then you are connected and it is either debugging is not on or RSA Encryption key error.

Rebooting requires holding down the home key until it says rebooting usually forces an RSA request that was not approved but won’t force one that is approved. Resetting a watch certainly will force it.

You didn’t mention it but did you turn on Developer Options by tapping on the software version 5 times? (in the about watch settings).

Also (This is a GWS trick but should work for Tizen Studio too)
Try C:\users\USERNAME.tizen and rename sdbkey and sdbkey.pub and see if that forces it.

A trick is to have a preinstalled watch face running when you try to launch device manager that keeps the RSA Encryption on longer.

Ron
Samsung Developer Program

Thanks for the tip with the watch face.
Yes developer mode was always enabled. the GWS trick did not work.

I just switched to a different pc and then i worked first try without a hitch. So something has to be wrong with my pc. which is strange because:

  • it worked a few days ago with this exact pc
  • I even uninstalled and the reinstalled tizen studio multiple times

well at least it works now, thanks!

I had trouble connecting too after I had reset my watch (paired to a different phone) it was a series of silly mistakes starting iwith a different IP address and forgetting to turn on debugging. Once it reconnected all was fine but It sounds like you had all this covered.

Glad you got it, at least now you know it isn’t the watch.

Ron
Samsung Developer Program

I had the same problem, i resolved it the follow way:
when I activated the developper mode in my tv, put my address ip and restart the tv.

you can know your ip address typing ipconfig in your cmd console.
After go to remote device manager in Tizen studio, you do not need add the new connection, only scan and voila, you tv samsung will appear in your list, now you can connected to tv and install or create apps.