"Create Your First Tizen Wearable" : UI Hangs, Kernel Not Booting, No Log Info


I’m new to Tizen and am trying the sample app at https://docs.tizen.org/application/web/get-started/wearable/first-app/#create

Latest Tizen Studio (3.7) is running in a 64-bit VMWare instance of Ubuntu 16.04.6 LTS (Linux ubuntu 4.15.0-45-generic #48~16.04.1-Ubuntu SMP x86_64)

At the point where I run the application, the Wearable is supposed to display, “Hello Tizen” but it just hangs at “Booting the Kernel”. It’s been there for minutes and no log entries have been made.

Is there a configuration issue I’m missing? What do I need to check in Ubuntu or Tizen to be sure the environment isn’t missing something? I’m not seeing anything in the instructions.

I’ve also done the following, per Ubuntu requirements:

  1. sudo apt-get install libwebkitgtk-1.0-0 cpio rpm2cpio

  2. sudo apt-get install acl bridge-utils openvpn libfontconfig1 libglib2.0-0 libjpeg-turbo8 libpixman-1-0 libpng12-0 libsdl1.2debian libsm6 libv4l-0 libx11-xcb1 libxcb-icccm4 libxcb-image0 libxcb-randr0 libxcb-render-util0 libxcb-shape0 libxcb-xfixes0 libxi6

Thanks for your help!

You are creating a Tizen Wearable 5.5 app and in your project settings it shows a Mobile 4.0 emulator setting.

It is a pain but the easiest way to clear this and any caches is to restart Tizen Studio. If Emulator Manager is running or any emulators running close them before you restart Tizen Studio.

Be sure the emulator is the 5.5 version but remember there are not Watches that support Tizen 5.5 at this time so you can’t test on a device.

Samsung Developer Program


I was able to duplicate this myself with the Tizen 5.5 emulator and Tizen 5.5 project but I dialed it back to Tizen 4.0 an Tizen 4 Emulator and all worked fine. I don’t think the new emulator is without bugs.

Samsung Developer Program

Yeah, I noticed the diff between the emulator setting and the 5.5 device I selected also, but I couldn’t change the pull-down while the IDE was up. So, I’ll exit and come back in to clear the cache.

So, just so I understand, you were not able to get the 5.5 versions to work but the 4.0 versions worked?

Hmm, so I synced the project select, 4.0 Basic UI with a 4.0 profile in the pulldown, but it still didn’t work. However, I noticed that the profiles all end with x86. Since I’m running on a 64-bit Ubuntu VM, I assumed it wouldn’t make a difference, but is that correct? What is the configuration you’re using that is correctly launching the emulator?

I waited patiently this try and got both the 4.0 and 5.5 emulator to work correctly for the Basic UI web template.

Launch Tizen Studio.
Build the project if you haven’t already but don’t run it
Launch the emulator manager
from the emulator Manager launch the W 5.5 Circle emulator
go get a cup of coffee it takes forever to launch it gets to the blank screen then took several more minutes to actually show the watch face.
It should end up looking like the attached image after about 5 minutes
W5-5 Circle
Make sure the W 5.5 Circle is the emulator in the menu bar next to the emulator manager icon. In the screen shot you had it listed the mobile emulator.
It took a long time to get there but then running from Tizen Studio went fairly quickly and loaded on the emulator.

If you don’t get to the default clock screen let us know. My issue in previous attempts was lack of patience and this really took patience.

Samsung Developer Program

It’s still hanging after 47 minutes, as you can see by these two screen pics. The Microsoft Windows versions of Tizen Studio work fine, but the Ubuntu ones don’t. I really want to the Ubuntu VM version working, though. I must still be overlooking something. Is there a debug mode or something in the OS config I should check/verify?

Some tips from my Tizen developing experience. Maybe it helps you.

  1. I recommend to use emulator for Tizen 4.0. Tizen 5.0 is not published yet. Maybe there are still some bugs yet or was not tested fully.

  2. Emulator issue like yours usually was affected by incorrect version Java environment.

  3. So far emulators worked correctly only on Intel-based cpu because of specific hardware support. I am not sure about last tizen sdk.

Thanks, Andrzej, however, I’m using Tizen Studio 3.7, which I thought was installed with it’s own Java. What release of Tizen Studio are you using? Which Java version, Oracle or OpenJDK and what version?

I use Oracle version and still rather old Tizen 3.3 because Windows 7. However, I am going to update both windows and tizen studio soon. Please check system requirements for Tizen Studio 3.7 to make sure you met all. Running tizen emulator always was like a pain in the neck but finally it always worked.

Sounds good, on Windows 10, I had no problem running Tizen Studio 3.7 and getting the Emulator to run Wearable 5.5 Basic UI. In fact, the Emulator ran very quickly (seconds).

As for Ubuntu platforms, I’m still hoping for some answers and I have a few things to still try. Hoping Samsung Support will have some answers, too.

As far as I know the Java JRE 8 is the last publicly released version of Java and it is supported. I was able to use Java 9 and 10 as an Oracle member but I didn’t have any luck with Java 11 the last I tried.

To launch Device Manager you need JAVA_HOME set to
C:\Program Files\Java\JREx.xx.xx
To Launch the Emulator Manager you need the path to include
C:\Program Files\Java\JREx.xx.xx\bin

but I think since you can launch the Emulator Manager your settings are correct.

Make sure CPU VT is on see This Thread

There are also emulator issues with AMD card if your system has that it may never work.

Samsung Developer Program

Ok, following the directions in the CPU TV Thread link response above, I was able to get the Wearable 5.5 project to run. Steps were:

  1. Since Ubuntu 16.04 is running in VMWare Workstation 15.5, there were some settings I had to enable to allow virtual machine threading (CPU TV) within the Ubuntu VM. In the Virtualization engine section below, check “Virtualize Intel VT-x/EPT or AMD-V/RVI”. Also, if the Emulator is running slowly and you have more processors to devote to the virtual machine, change the pulldown, “Number of processors” to your computer’s max. In my case, I changed it to 4.

  2. In the Emulator, Select Edit to bring up the Emulator Configuration. Select “HW Support” and change “CPU VT” to ON. I found that if I don’t turn on “Virtualize Intel VT-x/EPT or AMD-V/RVI” in step 1, this step won’t allow “CPU VT” to be turned on, like below.

    A similar restriction might be in place if you’re running Ubuntu in VirtualBox, but I’ve not tried that.

  3. With the Ubuntu packages I installed, mentioned earlier, the VM ran faster, as did Tizen Studio, and the Emulator brought up the watch in seconds, like below. For some reason, the watch face would appear, then disappear and I had to hit the power button then select the Back button on the watch (upper right) to get the watch face to appear, as below. But it happened in seconds vs. many minutes.

I went back to the instructions for configuring Ubuntu 18.04 to run Tizen 3.7 and its Emulator and was able to run the 5.5 Wearable Basic UI. The VMWare and Emulator settings to CPU VT appeared to be the key.

Hope this helps someone else. Thanks for everyone’s ideas.

I didn’t expect to worry about Java JRE, since Tizen Studio 3.7 comes with its own JDK (https://www.tizen.org/blogs/bighoya/2020/announcing-tizen-studio-3.7-release). Does that also apply to the Emulator?

I need to update to TS 3.7 I’ll let you know.

Thanks for the update it will help others. I’m glad you got it working !!

Samsung Developer Program

looks like there is a problem with some redistributive

my friend got the similar issue and nothing helped until he completely wiped out all installed C++ redistributive on his PC and reinstalled the studio

Did you manage to make it work in the end?

Yep, I finally got it to work in Ubuntu 18 and 16 (steps I took above) and the final key was in setting VMWare to support the Kernel-based Virtual Machine(KVM)-Linux used by the Emulator to run within the Ubuntu VM, coupled with turning on hardware virtualization support (turning on the CPU TV switch in the Emulator, https://developer.tizen.org/development/tizen-studio/web-tools/running-and-testing-your-app/emulator) (pics below).
I never had a problem however on Windows 10. I wouldn’t be surprised if there are many moving parts like the C++ redistributive that can throw it off.

1 Like