Web applications not launching on wearable emulator

Hi. I’m running the wearable 5.5 emulator in Windows 10 for the first time but while it starts and looks fine, none of the sample web apps are being launched (the emulator keeps showing the standard watch face).

I can see several errors in the log, this one stands out:

[0mstc-manager-gdbus.c: stc_manager_gdbus_call_sync(457) > g_dbus_connection_call_sync() failed error [36: GDBus.Error:net.stc.iptables.Error.Failed: OPERATION_FAILED]

Does anybody have any idea of what can be wrong?

Did you get this sorted out. Are you using Tizen 4.1? Have you successfully built the examples with Tizen 4 and Tizen 4 emulator?
If you let me know what example you are using I can try it.

Samsung Developer Program

Hi Ron.

I’m still having the same issue, I cannot run any of the sample web apps in the wearable emulator, I have tried BasicUI, AlarmUI, Mini Gallery and the Calculator.

I’m not doing any modifications, I just open Tizen Studio -> New -> Tizen Project -> Sample -> Wearable 5.5 (or Wearable 4.0) -> Web Application -> select any sample. Then after the project loads I right click on it and select Run As -> Tizen Web Application. The watch emulator loads but keeps showing the watch face and the app never shows up.

If I use Run As -> Tizen Web Simulator Application instead then the apps load fine.

I’m adding another log with the errors I’m seeing when I click on the samples after they are deployed and installed on the watch emulator by Tizen Studio.emulator-26101 (W-5.5-circle-x86)-log.txt (14.8 KB)

When I tried to run on the work computer which has firewalls it would load the watch face but not run the calculator app. However, when I ran it from my home computer without the company firewall it loaded the calculator app.

Could that be an issue you are seeing. If not then send the information as a Support Request.

Samsung Developer Program