Error behavior in Weather Complication

Hello,
I created a complication which displays weather. (Short Text Complication)
The display in NORMAL Mode is OK, but not so in ALWAYS ON Mode.
I can also see the weather Info in ALWAYS ON Mode, but in this mode I have deactivated this info.
In other words, in ALWAYS ON Mode the visibility is OFF. Please help. Thanx.

Hello,
Welcome to this forum. I have tested but on my end the issue is not occurring.
Did you change the complication visibility from the Watch face Studio? Check the below image.

change visibility
.

Hello,
as I wrote, I have deactivated the visibility in “Always ON” Mode, not in NORMAL Mode.
So I see the weather in NOMAL Mode, this is OK, but I don’t want to see it in “ALWAYS ON” Mode.

For this, you have to change the visibility. If you change the visibility then the complication will not be shown in AOD mode.
If I misunderstood your question please correct me.

Hi Boshra,
Yes I’ve changed the visibility in AOD mode to “Not visible”, but it will not work.

Are you seeing this in the emulator window or the work window or on your watch? If it is only on your watch did you hide the complication or the individual components of the complication?

Ron
Samsung Developer Relations

The Work window

Hey @thomas1,
Could it be that you forgot to disable the sub-complication.

Even if it looks disabled in the emulator, if you disable only the group, it will be still visible on the real device until you disable all of them individually.

All in all, you “usually” can’t rely on the emulator preview when it comes to complications.

See video to better understand what I mean.

I hope I could help

Hi Vito, thanx for that cool little video.
And YES, that is exactly what I did. In Watch Face Studio it looks OK, but tranferred it to the Clock it is
not OK.

This is however issue which needs to be fixed urgently. In previous WFS version, it was only necessary to hide whole complication. Now we need to hide also every complication component in all layouts.

Same applies also to grouped elements

Be aware if you’re updating older watch faces with WFS 1.3.12

@Boshra @r.liechty_SDP

I found one work around for this and that is to group your complications and then show hide the group.

I think the bug is that the complications are not grouped, I wish they were by default. If they were then you wouldn’t be be moving one component when you mean to move the entire complication :slight_smile:

Ron

Thanx for the answers.

Hmmmmm, I’ve found out, that when I disable GPS, then it works.
Why ???

Hi Thomas,

Are you saying that the Hide complications is fixed if GPS or were you talking about your Weather would go blank and you had to restart the watch face issue?

Ron
Samsung Developer Relations

Yes, that behavior disappears when I disable the GPS on the watch.
After disabeling GPS, my own watch face is now working perfect.
But I thing, that is not really normal.

Unfortunately, the error came back today, despite the GPS being switched off. :frowning:

How can i add weather complications ?

How can i add weather complications ?

I think weather works with short text, long text and ranged value complications but the end user has to add it. The only default ones WFS are ones they are sure on all brands.

Ron
Samsung Developer Relations

It’s me again. I had some complications, where the borders of that complications cross other complications. So I arranged them so, that no one is in the area of another on.
Today, 16.01.23 I had no longer problem. I will keep you informed in the next days.

grafik

Today, 17.01.23, and my Watch Face is working perfect, no dropouts of the weather complication. :slight_smile:

Hi again, btw, this is my watch face.