Build fail Still

Even with the newest update and making sure my locations are correct I still get the build fail blank warning issue. I’ve had a few people tell me how to save and install this program and I have run it multiple times differently and nothing works.

Now on the other hand I can get this program to work on my girlfriends computer that is only a year old but not on mine that is much older which is odd. I can run the other watch program for the watch 3 but not this program which really sucks because now I’ll have to use both computers to make faces for her watch as I have all my adobe programs on my computer that run perfect and I don’t wanna install them on hers.

My laptop is a Toshiba satellite that’s maybe 8yrs old and still runs great and is running on SSD now. very odd it doesn’t run on mine but will on hers which also runs on SSD.

I am having that same problem

Hi Ross,
I looked at your bug report and there is another one with the same problem. Both of you did not fill out the keystore information either left it blank or put none in

CN=Unkown, OU=Unkown, O=Unkown, L=Unkown, ST=Unkown, C=Unkown

Try to put some information especially the Country 2 letter code. Did you Do that when you created the Keystore on your girlfriends computer?

Samsung Developer Relations

I Filled out all of the information creating the Keystore, and still get the error when I try to build

If all solutions did not fix it, last resort is to start a fresh project and rebuild it. Sometime recycling projects results into this issue or sometimes Image does not exist.

i have uninstalled. reinstalled made new quick things, and still get the error

Is your location for the build files an actual location and is a writeable folder? The build will not create it and will not have a specific error to show.
Did you create a new keystore.jks file in a totally different folder and point it to this?

Look in the log Windows : C:\Users{User}\AppData\Roaming\watchfacestudio\dump\main.log and see if you can spot what the error is. You can open it with a text editor. It is usually just before the end of the log. You may need to rename the current log before launching WFS and do it a build again to make it easier to read.

Hope that helps.

Samsung Developer Relations

it works on my laptop, and that’s all that matters. I’ll just transfer the save file to my laptop and build it… thanks anyways

HI ScrubLOrd,

Glad it is working on your laptop.

There is a new thread jOW not recognized and that was because the users keystore password had illegal characters Just an idea.

A valid password can contain 6 to 30 characters, begin with an alphabetic character, and use only alphanumeric characters and special characters like Underscore (_), Dollar ($), Pound (#). The password must contain at least one number.

Hi Ross,

See if you have a legal keystore Password another member just posted a weird error because his password wasn’t valid.
A valid password can contain 6 to 30 characters, begin with an alphabetic character, and use only alphanumeric characters and special characters like Underscore (_), Dollar ($), Pound (#). The password must contain at least one number.

Samsung Developer Relations

Hey Ron
Yep I filled it all out. Don’t know why it says it’s blank. I just tried it all again with different passwords and still won’t build. When I look inside the main log file I don’t see any errors. Here’s the newest dump file main log.

[1.1.9][3/4/20229:35:12 AM][Socket.(KeyStore.js:127)] stderr: Generating 2,048 bit RSA key pair and self-signed certificate (SHA256withRSA) with a validity of 9,125 days
for: CN=Ross , OU=Mine, O=Mine, L=Port , ST=Florida, C=
[1.1.9][3/4/20229:35:12 AM][Socket.(KeyStore.js:127)] stderr:

[1.1.9][3/4/20229:35:12 AM][Socket.(KeyStore.js:127)] stderr: [Storing C:\Users\rossp\WatchFaceStudio\keystore\keystore.jks]
[1.1.9][3/4/20229:35:12 AM][Socket.(KeyStore.js:127)] stderr:

[1.1.9][3/4/20229:36:21 AM][Object.(captureListener.js:84)] [childWin][OffScreen1][did-create-window] id: 4
[1.1.9][3/4/20229:36:22 AM][Object.(captureListener.js:86)] [childWin][OffScreen1][did-frame-finish-load] frameProcessId: 3, frameRoutingId: 10
[1.1.9][3/4/20229:36:22 AM][BrowserWindow.(captureListener.js:105)] [childWin][OffScreen1][close]
[1.1.9][3/4/20229:36:22 AM][BrowserWindow.(captureListener.js:126)] [childWin][OffScreen1][closed]
[1.1.9][3/4/20229:36:22 AM][BrowserWindow.(captureListener.js:127)] [childWin][OffScreen1] childWebContentMap: [RunPreview,2]
[1.1.9][3/4/20229:36:22 AM][Object.(captureListener.js:99)] [childWin][OffScreen1][destroyed]
[1.1.9][3/4/20229:37:53 AM][BrowserWindow.(captureListener.js:105)] [childWin][RunPreview][close]
[1.1.9][3/4/20229:37:53 AM][BrowserWindow.(captureListener.js:107)] [childWin][RunPreview] it will be hide
[1.1.9][3/4/20229:37:54 AM][BrowserWindow.(captureListener.js:126)] [childWin][RunPreview][closed]
[1.1.9][3/4/20229:37:54 AM][BrowserWindow.(captureListener.js:127)] [childWin][RunPreview] childWebContentMap: [RunPreview,2]
[1.1.9][3/4/20229:37:54 AM][Object.(captureListener.js:99)] [childWin][RunPreview][destroyed]

Here’s pics of what I filled out.


I removed the image with your personal information.

I see you have a support request and I am being copied on that. If I think of anything I’ll let you know on that ticket. None of the issues I know of seem to be there.


Oh I went to delete your log info and noticed you have Florida for your country it has to be a 2 digit country code US