WFS 1.0.12 project not building

I had started a watch face project with the older version of WFS 1.0.3 and I opened it using the latest version 1.0.12 and when I try to build it, build progress goes to 100% immediately and I get an empty warning box and nothing happens after that. The warning box is empty so I don’t know what the warning is. Run on Device is working fine though.

If I try to build it again, the build gets stuck at 0 and the WFS hangs.

Any idea how to fix this?

I have also 2 x watchfaces which i started in 1.0.3 and i tried to build them after 1.0.12 update and it says failed to build.

Those built on 1.0.11 have no issues when i built them again on 1.0.12


We need the log from PC right after this issue is happened to investigate the issue.

Path of the log:
Window : C:\Users{User}\AppData\Roaming\watchfacestudio\dump\main
macOS : /Users/User Name/Library/Application Support/watchfacestudio/dump/main

Please report this issue as a bug from Support>Developer Support and share the log while submitting the bug report. Please don’t share the log in this forum.

Thank you.

Also upgraded from 1.0.3 to 1.0.12.
wfs built in 1.0.3 did not build.

Also when creating an analog watch face When the watch 4 screen turns off and on The needle jumps.

Version 1.0.12 also has a serious bug.
After downgrading the version to 1.0 3 It works fine as before.

Thank you. Just reported the bug.

Thank you for your feedback.

I’d like to request you two things.

  1. Before installing 1.0.12, could you uninstall the previously installed tool and check it again?
  2. Could you share the version information in Main menu > About > Help?

I deleted the watch face studio app and removed the watchfacestudio directory from /Users/<User_Name>/Library/Application Support/ and reinstalled the app. The same issue is happening with the new installation as well.

Version: 1.0.12

Thank you for your feedback.

It seems that there is a possibility that the wrong value will be included in the location path due to this feature. “Provide used build information in Build information. - Supported from 1.0.11.”

Could you check if the issue remains after re-setting the “Location” in Build dialog?
The default path is {workspace}\build{project name}.

Yes, this worked. Thank you.

I hope this will be fixed in the next version though.

Thank you for checking. We will solve the issue in the next release.
Have a good day~!

1st screenshot
i dont know whats wrong but i cannot run a recently uploaded watchface. i open the wfs and try to run it and it says build failed.

2nd screenshot
then i try to use the build option and it starts and then says font file not found. i have tried changing workspace and doing clean install

has started to happen lot now on different wfs projects which i never had any issues previously. its really disturbing to remake already build and completed projects, just because you edited in 1.0.12.

I have checked the dump log. it says that no fonts are present in the res folder.also includes all bitmap fonts. im going to try adding all fonts again . i have inspected the wfs with winrar and the fonts folder inside is empty .there are no fonts inside.

I have managed to restore back and make the build work.

But i had to literally swap every image again because the log indicated after font correction about all images also missing

I had to add all bitmap font images as well. That means i had to literally add everything again .AT least formatting and text tags worked didnt have to do them again.