Error WO: WO: 9012

I just received a test report:
Unable to install the application after download
Error pop-up: Installation failed. Try later.(WO:WO:9012)
1. Install the application
2. Check the pop-up occur
[Expected Result]
The application should be installed without error
[Test Device Info]
Detected Device: SM-G960N_SM-R845U, SW Version: G960NKSU1NRH1_R845USQU1BTK2

I am using GWS 2.0.0_beta.

I did everything as always. I haven’t had any errors like this before.
The watch face works fine on my GW46, GW3 and active 1 devices.

Has anyone encountered this error? What have you done to correct this error?

It looks like this is on a S9 and GW3 watch
But I believe this is because you included Gear S2 devices in your compatible devices.
If this is not the case then it may be you need to upload Tizen 3 tpk and I can explain that too.

To exclude Gear S2

When you submit a round watch to the Galaxy Apps store you must select all watches 360 x 360 watches in a group to be tested. However, with Galaxy Watch Designer 1.7 or newer, S2 devices are not supported. This causes a validation error you will get because they test on S2 device and it will not install. Here is what you need to do to rectify the problem.

  1. Go to the “Binary” section of the “Add New Application” web page.
  2. Upload your binaries as usual.
  3. Next to the field “Add More Binary”, click on the number behind “Selected Device(s)”, which should read about 1766 or more.
  4. A dialog window with a large list of hardware combinations shows up. Don’t get confused.
  5. In the search field at the top right enter “Gear S2” - no need to press Enter.
  6. The displayed list now only contains hardware combinations including the S2 watch.
  7. Now uncheck the check box “Select all”.
  8. Despite the message still reads 1766 or more devices selected", you have in fact deselected all S2 combinations, about 314+
    9.Click the “Save” button at the bottom.
  9. The dialog window closes and your device number(s) should now be down to around 1400 (if tpk4 only) or so.
  10. Save and then submit

Samsung Developer Program

Hi Ron.

I do this every time.

Now I saved the gwd file with a new name and created new tpk files. Perhaps this will fix the problem. If the problem persists, I will bring this up again.

Maybe I helped someone else. :slight_smile:

When you rebuild check AOD mode, developer options override AOD errors and allow installation. Sometimes that bites the designer with custom fonts or OPR that is on the edge.

I don’t know if the review team will put you to the head of the list or back of the list for reviews. Please let me know if you get a quick review so I can advise others.

Thanks and best luck

Samsung Developer Program

Max OPR was 14.5%. I reduced the value to 12.6%.

If it does not help, then I will redo the AOD mode. I will let you know when I have new information.

That is not enough , I recommend no more than 10% just to be safe. I’ve heard of borderline cases that don’t install.

Samsung Developer Program

The problem has been resolved. I did:

  1. I saved the gwd file with a new name and created new tpk files.
  2. I have lowered my OPR to 12.6%.