Font off center

For some reason, the 4, and only the 4 on my watch face, when I run it on my watch, will be off center. In the Watch Face Studio, it looks on center. Any clue why this is? All other numbers in watch face studio, and while running on my GW4 are on center.

I even edited my font files, to add space on one side of the glyph, to try and compensate and center it. It doesn’t seem to do anything.


Have you tried to replace the font for a while and switch it back to yours.
From my experience sometimes it helps.
If not, see how the number 4 is built in the font file, maybe it has certain settings wrong/different than other numbers.

Hello, I am not sure how, or why, does the watch handle the font differently than WFS, but to me it seems like the screenshot from watch has the digit 4 exactly in center of the circle. That it does not look good, because it does not equal mass centre of the digit and you would like it more to the left to ballance it, is different thing. From your first image it seems to me, like the whole text field was shifted to left in the WFS off-center and the watch displays it shifted a bit to right. Nice design btw. :slight_smile:

1 Like

All other numbers on WFS, and on device are center. I did, take into consideration, the weight of the design of the 4, being one sided. I tried compensate for it, by adding more space on that side of the glyph, to push it to the other side slightly. But it doesn’t matter how much space I add, it doesn’t seem to move its position on device. I used Fontself for illustrator. I added that spacing in fontself, not in WFS. So the TTF file itself, has that spacing.





And thanks, I acutely impressed myself with this design. Turned out better then I imagined it.

Maybe a trick I used in a different face making program could help. Add one letter at beginning of the text field, then add like many spaces, then your tag, again same number of spaces and again that letter. Add so many spaces so the first and last letter would end out of the screen, but will force the watch software to apply the spaces, while it should remain symetrical.

1 Like

So what I ended up doing is, centering the original raster image of the 4. Placing the 4 more on the left side. When I vectorized it, I grouped it with a small dot behind the 4, that is barely visible. I then grouped the 4, and that small dot, and placed it into the Fontself extension. This tricks the software into thinking that dot is apart of the glyph. And essentially shifting the 4 over to the left. It seems like it did the trick. But I’ll have to wait until tomorrow, to see how it worked out. lol

I’m not sure how to change the time on my watch to check it out. lol

1 Like

We realized the issue from BUG 1.0.12 FONT not on same location as in WFS.
It will be solved in next release.
Thank you for the reporting and sorry about inconvenience.