No watch found in GWS

I tried many many times but cannot get my galaxy watch 46mm lte connected.

I activated debugging on the watch.
I switched it off and restarted it.
I activated wlan.
The IP is 192.168.1.202

I Start GWS 2.0 and load a project.
I got the certificates.
I activate the watch an have it in settings menu for example.
I click on run on device in GWS.
The scanning starts but could not find the watch.

If I try to ping the IP with my pc it works and the watch answers.

What am I doing wrong to get a connection?

I also tried BT connection.
I get a connection via sbdoverbt on my mobile and the messages on the watch appears. I can gruant access. But I cannot find my galaxy s9+ connected via USB in the GWS… But I have access to the memory by usb.
The developper mode by tapping the Software Version is activated on my mobile.

Thank you in advance.

It is that darn RSA Encryption Key acknowledgement. Hold down the home key until it says rebooting it will take about 15 seconds or longer.
Restart (not turn off and on) your computer to clear any caches there as well.

Next time you go to connect to your watch with GWS look very closely at your watch and an RSA Key acknowledgement will pop up. OK it. This does not last very long and if you do not acknowledge it the watch will see it as an attempt to hack your device and set it to NO and not show again.

That should be all the problem since you were able to access the device to create the distributor certificate it is just that one thing blocking it.

By the way you might want to turn the developer options on by tapping on the software version 5 times in the about watch settings. If you accidentally have OPR too high for the AOD it will allow it to load.

Ron
Samsung Developer Program

Thank you for your answer.

The message popup was so short that i missed it.
Is there a Chance to get the message again?
I rebooted again but it seemed not to Show again.

Greetings, Heiko

Try again to reboot the computer and watch… Wait a full minute before connecting after they reboot.

FWIW this is necessary to comply with new Privacy laws in Europe, USA and elsewhwere

Ron

Thank you verry much.

I restarted both, now the wlan connection works fine and I can load my watch face to the watch.

But I am interested why the BT connection does not work.
I Start the sdboverbt app on my Phone.
I can connect to my watch.
I got the popup message on my watch and gurant access.
My mobile is connected by usb to the pc.
I have usb debugging on the Phone active.
I cannot find a device in GWD. The list does not show my mobile device.


Any good advice?

When you connect the phone to the computer you must allow file transfer. It stays for some time.
You may be required to acknowledge an RSA Encryption on the phone.
If you are connected to the phone by USB you will see the little Android icon in the Run on Device window
sdb over bluetooth 2

and after a few seconds the the watch will show up.
I think this requires another RSA Encryption Key acknowledgment because the data is now coming from your phone not the computer but I don’t remember exactly. If you get and android icon but no phone check the Samsung Device Bridge over Bluetooth app again and if it is connected then it needs that RSA Key you might have to reboot to trigger that.

I much prefer SDBoverBT myself as it eliminates my work firewall settings and I don’t have to unplug my Ethernet cable on my personal computer.

Ron
Samsung Developer Program

That is the reason why Samsung is failing. The problem was reported at least 1.5 years ago but the customers are still forced to struggle for hours & days with the same issue.

Again & again & again.

어머나 어머나 이러지 마세요
고객님의 마음은 …

1 Like