Having trouble connecting galaxy watch to computer

  1. PC environment: Windows 10 and Tizen Studio
  2. Description of error:
    a) Turn off watch Bluetooth and get watch on WI-fi get the IP address the watch is using
    b) open command prompt make sure I can ping that IP address and get replies
    c) open Tizen Studio and Then the Device manager and attempt to connect to the watch
    d) when that fails check the watch to make sure it still says It’s on the WiFi and has the same ip.
    e) Try again to ping that ip get replies
    f) change to the tizen tools folder and then type in "sdb connect " and the IP address
    g) it pause for a bit then says the connection failed.
    h) try again to ping the IP and still get good results
    i) Conclude there is a network connection between the two or the ping would have issues something else is causing it not to connect.
    3)Error device and country (e.g. Galaxy S20 - Galaxy Watch / UK): Galaxy Watch Active 2 / US


Go to settings → About Watch
scroll down to software version and tap on it 5 times to enable Developer Options
in About Watch → Settings scroll down further and turn on Debugging
If you had already done this then
make sure your computer is connected to the same WiFi as your Watch use the 2.4 Ghz if it is a two band modem.
Make sure the ethernet is unplugged or disabled so you are using the Wifi (sometimes it will still connect with the ether net plugged in but not always)
close and reopen Device manager and try again.
When you try to connect keep your watch active and look for the RSA Encryption and accept it this does not last long and if you miss it it will not ask again.
If that doesn’t work
Restart Computer and Watch to clear all caches.
(hold down the power button for about 15 seconds until it says restarting
After the watch restart you will have to accept RSA Encryption Key again
You may have to close and reopen Device manager several times. to force the RSA Encryption key select do not show again and accept.

It is a pain the first time then never is a problem again unless you pair to a new phone or upgrade hardware.

Ron

okay, I double checked that the Developer options was enabled, and the debugging was set to on.
I went into my router and turned off the 5ghz made sure the computer was still connected to wi-fi
turned off the bluetooth on the watch. rebooted the computer and reopened Tizen and device manager and made sure it had the ip that’s showing on the watch. and hit the connect button again. nothing

It sounds like you did not accept the RSA Encryption Key it does not last long and once it is ignored it doesn’t show up again.

Restart the Watch by holding down the power button until it says restarting (about 15 minutes) and restart (don’t turn off and on but restart) That will clear any caches and should force a restart

I’m pretty sure it isn’t this but also check in the package manager and make sure you have the wearable extension enabled in the configurations.

Ron
Samsung Developer Relations

If your watch will not pair to a phone, or if it randomly disconnects, restart your watch. You should also make sure the Galaxy wearable app is up to date, but it may be necessary to reset the app and unpair your watch.

MyGroundBiz