Galaxy watch studio converter import error

it was working fine and just like that an error occurred that pleas check the file and try again i know the file is good and i reinstall the converter its giving me same error pls help.

this is the error.

Be sure you don’t have any of the Limitations listed HERE

Be sure you are using the latest GWS converter tool v 1.0.5
No weather components, no Health other than Steps and Heart Rate
No non ASCII characters in your path
make sure any images or Fonts are in a path where the tool can read them.
Fonts also need to be installed in Windows/Mac not just available.
There was an issue with the keystore in previous version but I think that is fixed in the latest update.

Open a support request and they can tell you how to create a log and it should give more information.


idk i am sure that there is no limitations and i still not no luck.

This was a work around to a similar failure in the original GWS Converter tool. Use the Keystore created with Watch Face Studio instead of the one created by the GWS Converter tool.

If that doesn’t help then please open a Support Request. They can direct you to where the GWS Converter log is located and you can submit that so they can figure out the issue. I don’t know where they store that log.

Samsung Developer Relations

sure ill look into it.

There was a reply to another thread that reminded me of a manifest error.

The Application ID must have at least two segments (one or more dots).
Each segment must start with a letter.
All characters must be alphanumeric or an underscore [a-zA-Z0-9_].

so check your GWS project App ID does it have a segment that starts a number or a hyphen in it?


character are fine i checked but now its working i reinstalled it bunch of time, it started working again.

I’m glad to know that thanks for sticking it out. I think then it probably was a path issue.


1 Like