Gauge style CURRENT TEMP not syncing and not showing in RUN window

I am trying to create a gauge style temperature for the current temp. I created the gauge, added a hand, and I thought sync’d it properly for rotation. Two problems and one of them is making testing almost impossible…

#1 - “running” the watch face, changing the temperature does NOT move the hand but I know it is working because if I add a text current temp onto the watch face, the text is changing.

#2 - when I “think” I have it working, as I watch it over a couple days, the pointer just isn’t right… always off by a 5-10 degrees. I have tried changing the ROTATE PROPERTIES: ROTATE, I have tried adjusting the ROTATE: ANGLE, all to no avail. If I could #1 to work, I could probably figure it out, but now I am guessing.

guage rotate

Any suggestions?


Hi @pwbrama,

I have checked it and found the same problem (#1) in GWS run preview. I would suggest you to submit a support ticket to Samsung Developer Support and they can analyze it thoroughly.