Gettin a Timeout Occured Error on each of my Tizen Web Projects

When I run any of my Tizen Web Projects in Tizen Studio using Tizen Web Simulator, I get this error. Restarted my pc nothing changes. It used to work just last week.

EDIT: Obviously, I’ve tried all the suggested items listed in the image. Checking the connection and internet isn’t the issue.

After some investigation, I was able to figure out the issue. It has to do with Chrome version 119.
I installed an older version of Chrome 118 and opened the Web Simulator by link and I was able to view the application.

My guess the Web Simulator uses WebSQL and that was recently deprecated in version 119 of Chrome. Only knew this because my Tizen application specifically needs WebSQL to run properly and when my chrome automatically updated one day, the application wasn’t able to run.

EDIT: Not sure if its a complete solution, I sometimes still get the timeout occurred error.

Found the solution. Seems like Tizen Studio is using a version of chrome installed on my PC using 119. To fix the issue, I installed an older version of Chrome specifically version 118.0.5993.118. In Tizen Studio, go to Window → Preferences → Tizen Studio → Web → Chrome and then change the Location to the version of Chrome you want to use.

As stated in the last reply, it seems like it needs WebSQL reverting the chrome version to a version that still supports WebSQL everything will work as it should.


Thanks for the solution. I had moved this to Smart TV as that was the most likely place but I see it is a wearable so I moved it to the Tizen Watch forum.

If you want to publish this in Galaxy store remember you only have a couple weeks before it stops taking new Tizen Watch content.

Samsung Developer Relations